db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From scott hutinger <...@www.mprojects.Horrabin.wiu.edu>
Subject [doc] xerces2.6.2 and buffer bug
Date Fri, 25 Mar 2005 05:41:08 GMT
Jeff,

I think this problem should be resolved on the dita.xml page somehow to 
point to a xerces version that works.  Ant ships with the broken (in 
this case) version.  But then again, so does every j2se I tried.

My error yesterday on a file that had  no problems in it :
[pipeline] [Fatal Error] rrefdmrs.dita:14:32: XML document structures 
must start and end within the same entity.
 [pipeline] org.xml.sax.SAXParseException: XML document structures must 
start and end within the same entity.
 [pipeline]     at 
org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)

All my problems were pointing to the EOF, not to anything that looked 
strange.

http://issues.apache.org/jira/browse/XERCESJ-1016?page=comments#action_60012

http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/src/org/apache/xerces/impl/XMLEntityScanner.java?rev=1.24&sortby=date&only_with_tag=MAIN&view=log
http://cvs.apache.org/viewcvs.cgi/xml-xerces/java/src/org/apache/xerces/impl/XMLEntityScanner.java?r1=1.23&r2=1.24&only_with_tag=MAIN&sortby=date&diff_format=h


I would suggest moving to a newer version than xerces2.6.2 that was 
released 23-Feb-2004.  The above fix was Mon Oct 4 21:45:48 2004 UTC.

I haven't had problems with the gump (unreleased version)
http://brutus.apache.org/gump/public-jars/xml-xerces2/jars/xercesImpl-gump-23032005.jar 

http://brutus.apache.org/gump/public-jars/xml-xerces2/jars/xml-parser-gump-23032005.jar 

The problem with this, is we can't point to a gump version that will be 
around long.  This isn't good if a change creates an unstable build etc...
Anyone have some good ideas?

I think possibly to let others under linux x86(all that I have tried) 
build without problems something on the dita.xml page should reflect 
this problem.

scott

Mime
View raw message