db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean T. Anderson" <...@bristowhill.com>
Subject Re: Derby architecture/design documents
Date Wed, 26 Jan 2005 01:51:16 GMT
I should really clarify something.

If you check out the derby web site using the instructions in 
http://incubator.apache.org/derby/papers/derby_web.html and you want to 
build that site, you must build it using forrest 0.5.1 until I upgrade 
it to 0.6. (Some things need to be moved to different locations.)

I often build/test new pages in a tiny seed site because it builds so 
much faster. And for that I've been using forrest 0.6.

If you use forrest's v20.dtd, you can easily move xml files between 
0.5.1 and 0.6.

 -jean

Jean T. Anderson wrote:

> Dibyendu Majumdar wrote:
>
>> Jean wrote:
>>
>>> Excellent! Did you download forrest 0.6? That would be good. The 
>>> derby site is currently at 0.5.1, which I'm planning to upgrade to 
>>> 0.6 as soon as I can.
>>> ...
>>
>> I downloaded 0.5.1 but will switch to 0.6. 
>
> If you find yourself using 0.5.1, no worries, but I suggest using the 
> v20.dtd instead of the v12.dtd:
>
> <?xml version="1.0" encoding="UTF-8"?>
> <!DOCTYPE document PUBLIC "-//APACHE//DTD Documentation V2.0//EN" 
> "http://forrest.apache.org/dtd/document-v20.dtd">
> <document>
> ....
>
> Using the v20.dtd also apparently positions us better for the leap to 
> 0.7.
>
> -jean
>


Mime
View raw message