db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel John Debrunner <...@debrunners.com>
Subject Re: Hibernate problems with snapshot
Date Tue, 18 Jan 2005 03:49:26 GMT
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

acemccloudxx@comcast.net wrote:

> I tried running with the snapshot and upgrade=true. Didn't work.

No it wouldn't. Derby 10.1.0.x (the trunk) is marked alpha and alpha
code does not support upgrades. The download for the trunk states this
and that the trunk is not suitable for production. Maybe a similar
annotation could be made to the snapshot jars for 10.1.0.x.

Regardless of that, no upgrade code has been added to support upgrading
databases from 10.0 to 10.1. I did some early write ups of how upgrade
is handled in Derby, but now I think I owe the some specifics on what
code needs to be changed and how to add soft upgrade checks.

Dan.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.5 (MingW32)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFB7IdGIv0S4qsbfuQRAtzWAKDSsCiD7G6JtKZyCr9sIP1G1w2jIACdEIBt
nTjG1yJt2mNl/DcQ3Zb7dXk=
=hdkh
-----END PGP SIGNATURE-----


Mime
View raw message