db-derby-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jeremy Boynes (JIRA)" <derby-...@db.apache.org>
Subject [jira] Updated: (DERBY-73) Ability to compile under JDK1.5
Date Sat, 18 Dec 2004 16:57:16 GMT
     [ http://nagoya.apache.org/jira/browse/DERBY-73?page=history ]

Jeremy Boynes updated DERBY-73:
-------------------------------

    Attachment: derby_jdk15_build2.patch

I was originally concerned about defaulting the code version levels and thought it would be
better set in ~/ant.propeties.

Attached is a patch that sets the versions in modern.properties and reapplies the build.xml
changes. I am not able to test with Jikes.

> Ability to compile under JDK1.5
> -------------------------------
>
>          Key: DERBY-73
>          URL: http://nagoya.apache.org/jira/browse/DERBY-73
>      Project: Derby
>         Type: Improvement
>   Components: Build tools
>     Reporter: Jeremy Boynes
>  Attachments: derby_jdk15_build.patch, derby_jdk15_build2.patch
>
> Compilation fails when using JDK1.5 due to
> 1) no specification of language level
> 2) use of "enum" as identifier
> The language issue results in the use of the new StringBuilder class for string concatenation
resulting in code that will not run on earlier JVMs.
> Dropping the langauge level will allow it to compile but warnings are generated due to
the use of "enum" as an identifier; with 1.5 this becomes a reserved word

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://nagoya.apache.org/jira/secure/Administrators.jspa
-
If you want more information on JIRA, or have a bug to report see:
   http://www.atlassian.com/software/jira


Mime
View raw message