db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kahat...@apache.org
Subject svn commit: r1482252 - /db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml
Date Tue, 14 May 2013 08:40:39 GMT
Author: kahatlen
Date: Tue May 14 08:40:39 2013
New Revision: 1482252

URL: http://svn.apache.org/r1482252
Log:
DERBY-6213: Deprecate support for Java 5 and CDC

Fix build break when j15lib is defined. The classes in the
org.apache.derby.jdbc package now implement the JDBC 4 interfaces, but
they are still compiled against the JDBC 3 libraries, which don't
include all necessary classes. This patch makes them compile against
the JDBC 4 libraries instead.

Modified:
    db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml

Modified: db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml
URL: http://svn.apache.org/viewvc/db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml?rev=1482252&r1=1482251&r2=1482252&view=diff
==============================================================================
--- db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml (original)
+++ db/derby/code/trunk/java/engine/org/apache/derby/jdbc/build.xml Tue May 14 08:40:39 2013
@@ -33,48 +33,8 @@
   <property file="${properties.dir}/compilepath.properties"/>
 
 <!-- Targets -->
-  <target name="jdbc" depends="checkVMLevel,compile_jdbc3,compile_jdbc4,compile_jdbc42"/>
+  <target name="jdbc" depends="checkVMLevel,compile_jdbc4,compile_jdbc42"/>
 
-<!-- build targets which need JDBC 3.0 libs in the end-->
-
-  <target name="compile_jdbc3">
-    <javac
-      source="1.5"
-      target="1.5"
-      bootclasspath="${empty}"
-      nowarn="on"
-      debug="${debug}"
-      depend="${depend}"
-      deprecation="${deprecation}"
-      optimize="${optimize}"
-      proceed="${proceed}"
-      verbose="${verbose}"
-      srcdir="${derby.engine.src.dir}"
-      destdir="${out.dir}">
-      <classpath>
-        <pathelement path="${java15compile.classpath}"/>
-      </classpath>
-      <include name="${derby.dir}/jdbc/InternalDriver.java"/>
-      <include name="${derby.dir}/jdbc/AutoloadedDriver.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedDriver.java"/>
-      <include name="${derby.dir}/jdbc/ReferenceableDataSource.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedDataSourceInterface.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedXADataSourceInterface.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedConnectionPoolDataSourceInterface.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedBaseDataSource.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedDataSource.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedConnectionPoolDataSource.java"/>
-      <include name="${derby.dir}/jdbc/EmbedPooledConnection.java"/>
-      <include name="${derby.dir}/jdbc/Driver20.java"/>
-      <include name="${derby.dir}/jdbc/Driver30.java"/>
-      <include name="${derby.dir}/jdbc/EmbedXAConnection.java"/>
-      <include name="${derby.dir}/jdbc/EmbeddedXADataSource.java"/>
-      <include name="${derby.dir}/jdbc/XATransactionState.java"/>
-      <include name="${derby.dir}/jdbc/XAStatementControl.java"/>
-      <include name="${derby.dir}/jdbc/ResourceAdapterImpl.java"/>
-   </javac>  
-  </target>
-  
   <target name="compile_jdbc4" >
     <javac
       source="${compilerLevel16}"
@@ -92,9 +52,10 @@
         <classpath>
             <pathelement path="${java16compile.classpath}"/>
         </classpath>
-        <include name="${derby.dir}/jdbc/*40.java"/>
+        <include name="${derby.dir}/jdbc/*.java"/>
+        <exclude name="${derby.dir}/jdbc/*42.java"/>
     </javac>
-  </target> 
+  </target>
 
   <target name="compile_jdbc42" if="vmLevelIsAtLeast1.8">
     <javac



Mime
View raw message