db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Db-derby Wiki] Update of "NewJdkChecklist" by KatheyMarsden
Date Tue, 06 Nov 2012 18:00:48 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Db-derby Wiki" for change notification.

The "NewJdkChecklist" page has been changed by KatheyMarsden:
http://wiki.apache.org/db-derby/NewJdkChecklist?action=diff&rev1=1&rev2=2

  
  Below are the changes are needed with a major version upgrade. Typically there are not changes
needed in the Derby code for a new vendor, but of course only the tests will tell. 
  
-  * Change JVMInfo to add in the new version. This will be used for JMX information and also
internal version based decisions.  Example change  [[https://issues.apache.org/jira/browse/DERBY-5948
| DERBY-5948 ]
+  * Change JVMInfo to add in the new version. This will be used for JMX information and also
internal version based decisions.  Example change  [[https://issues.apache.org/jira/browse/DERBY-5948
| DERBY-5948 ]]
  
  
  
@@ -18, +18 @@

  
  Below are the changes needed for running Derby tests with a new JDK version or vendor:
  
-   * For the old harness a support file for the specific vendor and version is required.
 For Oracle jdk's these have the prefix jdk followed by the major and minor version, e.g.
jdk18. For IBM the prefix is ibm, e.g. ibm18. Example change: [[https://issues.apache.org/jira/browse/DERBY-5898
| DERBY-5898]
+   * For the old harness a support file for the specific vendor and version is required.
 For Oracle jdk's these have the prefix jdk followed by the major and minor version, e.g.
jdk18. For IBM the prefix is ibm, e.g. ibm18. Example change: [[https://issues.apache.org/jira/browse/DERBY-5898
| DERBY-5898]]
    * For branches 10.8 and older,  change org.apache.tools.sysinfo.Main to show the correct
JRE and JDBC version. Example change [[https://issues.apache.org/jira/browse/DERBY-5982 |
DERBY-5982]]. Note this is not required for 10.9 and later.
  
  

Mime
View raw message