db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Db-derby Wiki] Update of "NewJdkChecklist" by KatheyMarsden
Date Tue, 06 Nov 2012 17:59:12 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Db-derby Wiki" for change notification.

The "NewJdkChecklist" page has been changed by KatheyMarsden:
http://wiki.apache.org/db-derby/NewJdkChecklist

New page:
== Checklist for adding a new JDK for Derby Code, Tests and Build ==

This page collects a list of changes that may be needed when adding  a new JDK version, e.g.
java 8 or a new vendor or platform. This is a work in progress and is not at this time complete.
 Of course additional changes will be required to use new functionality, but this is a working
list of just what is required to get all the versions reporting correctly and tests to pass.
Changes are broken into three categories, derby code, derby tests and derby build. 



=== Derby Code ===

Below are the changes are needed with a major version upgrade. Typically there are not changes
needed in the Derby code for a new vendor, but of course only the tests will tell. 

 * Change JVMInfo to add in the new version. This will be used for JMX information and also
internal version based decisions.  Example change  [[https://issues.apache.org/jira/browse/DERBY-5948
| DERBY-5948 ]



===  Derby Test ===

Below are the changes needed for running Derby tests with a new JDK version or vendor:

  * For the old harness a support file for the specific vendor and version is required.  For
Oracle jdk's these have the prefix jdk followed by the major and minor version, e.g. jdk18.
For IBM the prefix is ibm, e.g. ibm18. Example change: [[https://issues.apache.org/jira/browse/DERBY-5898
| DERBY-5898]
  * For branches 10.8 and older,  change org.apache.tools.sysinfo.Main to show the correct
JRE and JDBC version. Example change [[https://issues.apache.org/jira/browse/DERBY-5982 |
DERBY-5982]]. Note this is not required for 10.9 and later.



=== Derby Build ===

Below are the changes needed to build with a new JDK version or vendor:
  
 * Changes to PropertySetter? Please complete.

Mime
View raw message