db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Db-derby Wiki] Update of "JunitVmIssues" by MyrnavanLunteren
Date Thu, 06 Aug 2009 22:01:49 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Db-derby Wiki" for change notification.

The following page has been changed by MyrnavanLunteren:
http://wiki.apache.org/db-derby/JunitVmIssues

The comment on the change is:
most of this section applies equally to MAC and IBM jvms.

------------------------------------------------------------------------------
  export IBM_JAVA_OPTIONS="-Xifa:off"
  }}}
  
- == Sun Java 1.4.2, 1.5 and 1.6: unlimited cryptography policies ==
+ == Java 1.4.2, 1.5 and 1.6: unlimited cryptography policies ==
  
- By default, in the Sun Java run-times, due to import control
+ By default, in the US-produced Java run-times, due to US export control
  restrictions, the version of JCE policy files that are bundled in the
  JDK(TM) 6 environment, allow "strong", but limited cryptography to be
  used. Some Derby tests, as of writing, only "EncryptionAESTest", will skip
@@ -108, +108 @@

      no unrestricted policy jars; cannot test AES encryption with encryptionKeyLengths 192
nor 256
  }}}
  then you lack the unlimited policy files. You can download and install
+ these files if you are in territories where there are no restrictions. 
- these files by heading to the following URL and follow the instructions
+ For Sun JVMS you can do this by heading to the following URL and follow the instructions
  in the bundle (this link currently gives Java 1.6 version; you can
  also find such bundles for Java 1.4.2 and Java 1.5 if you want to run
  tests with those versions):
@@ -119, +120 @@

  Downloads Java Cryptography Extension (JCE) Unlimited Strength
  Jurisdiction Policy Files 6".
  
+ For other jvms, please contact your vendor.
+ 

Mime
View raw message