db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhille...@apache.org
Subject svn commit: r727725 - /db/derby/code/trunk/build.xml
Date Thu, 18 Dec 2008 13:55:56 GMT
Author: rhillegas
Date: Thu Dec 18 05:55:56 2008
New Revision: 727725

URL: http://svn.apache.org/viewvc?rev=727725&view=rev
Log:
DERBY-3986: Stop dropping dummy files in the source tree in order to determine whether the
compiler is modern enough.

Modified:
    db/derby/code/trunk/build.xml

Modified: db/derby/code/trunk/build.xml
URL: http://svn.apache.org/viewvc/db/derby/code/trunk/build.xml?rev=727725&r1=727724&r2=727725&view=diff
==============================================================================
--- db/derby/code/trunk/build.xml (original)
+++ db/derby/code/trunk/build.xml Thu Dec 18 05:55:56 2008
@@ -99,19 +99,11 @@
 
   <target name="checkCompilerLevel" description="Make sure compiler level is Java 5 level
or higher.">
 
-    <property name="dummy.src" value="z.java"/>
-    <property name="dummy.class" value="z.class"/>
-    <echo file="${dummy.src}" message="public class z {}"/>
-    <delete file="${dummy.class}"/>
-
     <javac source="1.5" srcdir="${basedir}" failonerror="false">
       <include name="${dummy.src}"/>
     </javac>
 
-    <available property="compilerAtCorrectLevel" file="${dummy.class}"/>
-
-    <delete file="${dummy.src}"/>
-    <delete file="${dummy.class}"/>
+    <available property="compilerAtCorrectLevel" classname="java.util.Queue"/>
 
     <fail unless="compilerAtCorrectLevel" message="Compiler level must be Java 5 or later."/>
   </target>



Mime
View raw message