db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From kahat...@apache.org
Subject svn commit: r652914 - /db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java
Date Fri, 02 May 2008 21:12:21 GMT
Author: kahatlen
Date: Fri May  2 14:12:21 2008
New Revision: 652914

URL: http://svn.apache.org/viewvc?rev=652914&view=rev
Log:
DERBY-3658: Made LOBStateTracker work with soft upgraded databases
that don't support locators.

Merged fix from trunk, revision 652865.

Modified:
    db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java

Modified: db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java
URL: http://svn.apache.org/viewvc/db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java?rev=652914&r1=652913&r2=652914&view=diff
==============================================================================
--- db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java
(original)
+++ db/derby/code/branches/10.4/java/client/org/apache/derby/client/am/LOBStateTracker.java
Fri May  2 14:12:21 2008
@@ -105,6 +105,12 @@
                     if (locator == this.lastLocatorSeen[i]) {
                         // We are being called on the same row twice...
                         return;
+                    } else if (locator == Lob.INVALID_LOCATOR) {
+                        // The locator is invalid, probably because the
+                        // database is running in soft upgrade mode and
+                        // doesn't have the neccessary stored procedures.
+                        // Don't try to release an invalid locator.
+                        return;
                     }
                     this.lastLocatorSeen[i] = locator;
                     if (this.isBlob[i]) {



Mime
View raw message