db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From rhille...@apache.org
Subject svn commit: r586462 - in /db/derby/site/trunk: build/site/dev/derby_source.html src/documentation/content/xdocs/dev/derby_source.xml
Date Fri, 19 Oct 2007 14:04:09 GMT
Author: rhillegas
Date: Fri Oct 19 07:04:08 2007
New Revision: 586462

URL: http://svn.apache.org/viewvc?rev=586462&view=rev
Log:
DERBY-3117: Adjust build instructions on the website to reflect what we currently do.

Modified:
    db/derby/site/trunk/build/site/dev/derby_source.html
    db/derby/site/trunk/src/documentation/content/xdocs/dev/derby_source.xml

Modified: db/derby/site/trunk/build/site/dev/derby_source.html
URL: http://svn.apache.org/viewvc/db/derby/site/trunk/build/site/dev/derby_source.html?rev=586462&r1=586461&r2=586462&view=diff
==============================================================================
--- db/derby/site/trunk/build/site/dev/derby_source.html (original)
+++ db/derby/site/trunk/build/site/dev/derby_source.html Fri Oct 19 07:04:08 2007
@@ -243,22 +243,22 @@
 <h2 class="boxed">Software required to build Derby</h2>
 <div class="section">
 <p>
-Derby is designed to work in JDK1.3 (JDBC 2.0) and JDK 1.4 (JDBC 3.0)
-environments.
-For this reason both JDK1.3 and JDK1.4 are required for the build environment.
-The build is set up so that most of the code is compiled against JDK 1.3
-libraries so that no dependency on JDK 1.4 classes exist,
-except for the code that only runs in JDK1.4.
-In addition Derby's JDBC 2.0 implementation must compile against JDBC 2.0
-class definitions and naturally the JDBC 3.0 implementation against JDBC 3.0
-class definitions.
+Derby is designed to work in JSR 169, JDBC 3.0,
+and JDBC 4.0 environments. In addition, optional run-time
+code may take advantage of features introduced by Java 5.
+For this reason both JDK1.4 and Java 5 are required for the build environment.
+The build is set up so that most of the code is compiled against JDK 1.4
+libraries so that there are no dependencies on classes from higher
+levels of Java. A significant exception to this is the JDBC 4.0 code.
 </p>
 <p>
-The software required to build Derby is summarized in the table below.
+The software required to build the Derby mainline is summarized in the table below.
 However, doublecheck the 
 <a class="external" href="http://svn.apache.org/repos/asf/db/derby/code/trunk/BUILDING.txt">BUILDING.txt</a>
-instructions for installation locations before downloading the software.
-As of this writing, and with the exception of JDK 1.4/1.3 and Ant,
+instructions for installation locations before downloading the software. If
+you need to build an earlier version of Derby, please consult the
+BUILDING.txt in the appropriate code branch.
+As of this writing, and with the exception of the JDKs and Ant,
 the Derby build procedure expects most software to be installed in
 <span class="codefrag">${derby.source}/tools/java</span>
 (where <span class="codefrag">${derby.source}</span> is the root location of
the Derby source on
@@ -286,8 +286,8 @@
     
 <tr>
     
-<td colspan="1" rowspan="1"> Java Development Kit (JDK) release 1.4.x</td>
-    <td colspan="1" rowspan="1"> Any JDK 1.4.x, Java's reference implementation is
at
+<td colspan="1" rowspan="1"> Java Development Kit (JDK) release 5</td>
+    <td colspan="1" rowspan="1"> Any Java 5 JDK, Java's reference implementation is
at
           <a class="external" href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
     </td>
     
@@ -296,10 +296,10 @@
     
 <tr>
     
-<td colspan="1" rowspan="1"> Java Development Kit (JDK) release 1.3.x</td>
-    <td colspan="1" rowspan="1"> Any JDK 1.3.x, Java's reference implementation is
at
+<td colspan="1" rowspan="1"> Java Development Kit (JDK) release 1.4.x</td>
+    <td colspan="1" rowspan="1"> Any JDK 1.4.x, Java's reference implementation is
at
           <a class="external" href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
-     </td>
+    </td>
     
 </tr>
 
@@ -315,31 +315,11 @@
 
     
 <tr>
-       
-<td colspan="2" rowspan="1">
-       <strong>Extensions for Java Development Kit release 1.3.x</strong>
-       </td>
-    
-</tr>
-
-    
-<tr>
-          
-<td colspan="1" rowspan="1"> JDBC 2.0 Optional Package</td>
-          <td colspan="1" rowspan="1">
-		<a class="external" href="http://java.sun.com/products/jdbc/download.html">http://java.sun.com/products/jdbc/download.html</a>
-               (select "JDBC 2.0 Optional Package Binary")
-          </td>
-    
-</tr>
-
     
-<tr>
-          
-<td colspan="1" rowspan="1">Java Cryptography Extension (JCE) version 1.2.2</td>
-          <td colspan="1" rowspan="1">
-		<a class="external" href="http://java.sun.com/products/jce/index-122.html">http://java.sun.com/products/jce/index-122.html</a>
-	</td>
+<td colspan="1" rowspan="1"> Java Development Kit (JDK) release 6 (optional)</td>
+    <td colspan="1" rowspan="1"> Any Java 6 JDK, Java's reference implementation is
at
+          <a class="external" href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
+    </td>
     
 </tr>
 
@@ -348,7 +328,7 @@
 </div>
 
 
-<a name="N10128"></a><a name="How+to+build+Derby"></a>
+<a name="N1010C"></a><a name="How+to+build+Derby"></a>
 <h2 class="boxed">How to build Derby</h2>
 <div class="section">
 <p>
@@ -367,7 +347,7 @@
 </div>
 
 
-<a name="N1014B"></a><a name="How+to+test+Derby"></a>
+<a name="N1012F"></a><a name="How+to+test+Derby"></a>
 <h2 class="boxed">How to test Derby</h2>
 <div class="section">
 <p>
@@ -393,7 +373,7 @@
 </div>
 
 
-<a name="N10175"></a><a name="How+to+submit+a+patch"></a>
+<a name="N10159"></a><a name="How+to+submit+a+patch"></a>
 <h2 class="boxed">How to submit a patch</h2>
 <div class="section">
 <p>
@@ -407,7 +387,7 @@
 
 <p>
 
-<em>Last updated: November 28, 2006</em>
+<em>Last updated: October 16, 2007</em>
 
 </p>
 

Modified: db/derby/site/trunk/src/documentation/content/xdocs/dev/derby_source.xml
URL: http://svn.apache.org/viewvc/db/derby/site/trunk/src/documentation/content/xdocs/dev/derby_source.xml?rev=586462&r1=586461&r2=586462&view=diff
==============================================================================
--- db/derby/site/trunk/src/documentation/content/xdocs/dev/derby_source.xml (original)
+++ db/derby/site/trunk/src/documentation/content/xdocs/dev/derby_source.xml Fri Oct 19 07:04:08
2007
@@ -132,23 +132,23 @@
 <title>Software required to build Derby</title>
 
 <p>
-Derby is designed to work in JDK1.3 (JDBC 2.0) and JDK 1.4 (JDBC 3.0)
-environments.
-For this reason both JDK1.3 and JDK1.4 are required for the build environment.
-The build is set up so that most of the code is compiled against JDK 1.3
-libraries so that no dependency on JDK 1.4 classes exist,
-except for the code that only runs in JDK1.4.
-In addition Derby's JDBC 2.0 implementation must compile against JDBC 2.0
-class definitions and naturally the JDBC 3.0 implementation against JDBC 3.0
-class definitions.
+Derby is designed to work in JSR 169, JDBC 3.0,
+and JDBC 4.0 environments. In addition, optional run-time
+code may take advantage of features introduced by Java 5.
+For this reason both JDK1.4 and Java 5 are required for the build environment.
+The build is set up so that most of the code is compiled against JDK 1.4
+libraries so that there are no dependencies on classes from higher
+levels of Java. A significant exception to this is the JDBC 4.0 code.
 </p>
 
 <p>
-The software required to build Derby is summarized in the table below.
+The software required to build the Derby mainline is summarized in the table below.
 However, doublecheck the 
 <a href="http://svn.apache.org/repos/asf/db/derby/code/trunk/BUILDING.txt">BUILDING.txt</a>
-instructions for installation locations before downloading the software.
-As of this writing, and with the exception of JDK 1.4/1.3 and Ant,
+instructions for installation locations before downloading the software. If
+you need to build an earlier version of Derby, please consult the
+BUILDING.txt in the appropriate code branch.
+As of this writing, and with the exception of the JDKs and Ant,
 the Derby build procedure expects most software to be installed in
 <code>${derby.source}/tools/java</code>
 (where <code>${derby.source}</code> is the root location of the Derby source
on
@@ -169,17 +169,17 @@
     </tr>
 
     <tr>
-    <td> Java Development Kit (JDK) release 1.4.x</td>
-    <td> Any JDK 1.4.x, Java's reference implementation is at
+    <td> Java Development Kit (JDK) release 5</td>
+    <td> Any Java 5 JDK, Java's reference implementation is at
           <a href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
     </td>
     </tr>
 
     <tr>
-    <td> Java Development Kit (JDK) release 1.3.x</td>
-    <td> Any JDK 1.3.x, Java's reference implementation is at
+    <td> Java Development Kit (JDK) release 1.4.x</td>
+    <td> Any JDK 1.4.x, Java's reference implementation is at
           <a href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
-     </td>
+    </td>
     </tr>
 
     <tr>
@@ -190,24 +190,10 @@
     </tr>
 
     <tr>
-       <td colspan="2">
-       <strong>Extensions for Java Development Kit release 1.3.x</strong>
-       </td>
-    </tr>
-
-    <tr>
-          <td> JDBC 2.0 Optional Package</td>
-          <td>
-		<a href="http://java.sun.com/products/jdbc/download.html">http://java.sun.com/products/jdbc/download.html</a>
-               (select "JDBC 2.0 Optional Package Binary")
-          </td>
-    </tr>
-
-    <tr>
-          <td>Java Cryptography Extension (JCE) version 1.2.2</td>
-          <td>
-		<a href="http://java.sun.com/products/jce/index-122.html">http://java.sun.com/products/jce/index-122.html</a>
-	</td>
+    <td> Java Development Kit (JDK) release 6 (optional)</td>
+    <td> Any Java 6 JDK, Java's reference implementation is at
+          <a href="http://java.sun.com/j2se/">http://java.sun.com/j2se/</a>
+    </td>
     </tr>
 
 </table>
@@ -273,7 +259,7 @@
 </section>
 
 <p>
-<em>Last updated: November 28, 2006</em>
+<em>Last updated: October 16, 2007</em>
 </p>
 
 </body>



Mime
View raw message