db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Db-derby Wiki] Update of "DeveloperGuideTenTwo" by DeepaRemesh
Date Fri, 01 Sep 2006 22:51:52 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Db-derby Wiki" for change notification.

The following page has been changed by DeepaRemesh:
http://wiki.apache.org/db-derby/DeveloperGuideTenTwo

------------------------------------------------------------------------------
  ||[#deployapps Deploying Derby applications] || || ||
  ||[#serverside Derby server-side programming] || || ||
  ||[#controlapps Controlling Derby application behavior] || || ||
- ||[#j2eerm Using Derby as a J2EE resource manager] || || ||
+ ||[#j2eerm Using Derby as a J2EE resource manager] || Deepa || ||
- ||[#security Derby and Security] || || ||
+ ||[#security Derby and Security] || Deepa || ||
- ||[#developwithide Developing tools and using Derby with an IDE] || || ||
+ ||[#developwithide Developing tools and using Derby with an IDE] || Deepa || ||
- ||[#sqltips SQL tips] || || ||
+ ||[#sqltips SQL tips] || Deepa || ||
- ||[#localizing Localizing Derby] || || ||
+ ||[#localizing Localizing Derby] || Deepa || ||
- ||[#standards Derby and standards] || || ||
+ ||[#standards Derby and standards] || Deepa || ||
  
  === Sub Section Details ===
  
@@ -53, +53 @@

  
  [[Anchor(security)]]''' Derby and Security:'''
  ||'''Sub Section''' || '''HTML Url''' or '''PDF Page''' || '''Reviewer'''|| '''Comment'''
||'''Resolution''' ||
+ ||Built-in Derby users ||http://db.apache.org/derby/docs/dev/devguide/cdevcsecure21547.html
||Deepa ||To keep the terminology consistent, "These user names are case-sensitive for user
authorization" should be changed to "These user names are case-sensitive for user authentication".
||  ||
+ ||Notes on the Derby security features ||http://db.apache.org/derby/docs/dev/devguide/cdevcsecure10983.html
||Deepa ||This statement should be removed "Because Derby does not support traditional grant
and revoke features, the security model has some basic limitations." as grant/revoke is supported
now. I think the following two lines "For both embedded and client/server systems, it assumes
that users are trusted. You must trust your full-access users not to perform undesirable actions."
can also be removed. ||  ||
  
  
  [[Anchor(developwithide)]]''' Developing tools and using Derby with an IDE:'''

Mime
View raw message