db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Wiki <wikidi...@apache.org>
Subject [Db-derby Wiki] Trivial Update of "ForwardCompatibility" by DavidVanCouvering
Date Wed, 21 Jun 2006 21:09:08 GMT
Dear Wiki user,

You have subscribed to a wiki page or wiki category on "Db-derby Wiki" for change notification.

The following page has been changed by DavidVanCouvering:
http://wiki.apache.org/db-derby/ForwardCompatibility

------------------------------------------------------------------------------
       * Dropping support of JDK 1.3/JDBC2.1. Technically a regression but it seems unlikely
that by the time the community does this that there will be any demand for JDK 1.3. (We've
voted that it's ok to do this in 10.3, but someone has to scratch that itch)
  
  Users of Derby have several options under the hopefully rare occasion that a new release
breaks their application:
-    - Fix their application
+    * Fix their application
-    - Use the old release (i.e., don't upgrade)
+    * Use the old release (i.e., don't upgrade)
-    - Pay someone who is supporting Derby to fix their problem.
+    * Pay someone who is supporting Derby to fix their problem.
-    - Get involved in the Derby community and suggest/provide a fix to their problem.
+    * Get involved in the Derby community and suggest/provide a fix to their problem.
-    - Patch the source in their local copy of the Derby source code by reverting the fix
that causes the problem for them.
+    * Patch the source in their local copy of the Derby source code by reverting the fix
that causes the problem for them.
  
  == What is an Interface? ==
  

Mime
View raw message