db-derby-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fuzzylo...@apache.org
Subject svn commit: r126307 - /incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java
Date Mon, 24 Jan 2005 19:33:54 GMT
Author: fuzzylogic
Date: Mon Jan 24 11:33:53 2005
New Revision: 126307

URL: http://svn.apache.org/viewcvs?view=rev&rev=126307
Log:
Fix for DERBY-122. Do not skip jdk14 suite under JDK 1.5/5.0

Committed for Myrna Van Lunteran <myrna@golux.com>

Modified:
   incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java

Modified: incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java
Url: http://svn.apache.org/viewcvs/incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java?view=diff&rev=126307&p1=incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java&r1=126306&p2=incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java&r2=126307
==============================================================================
--- incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java
(original)
+++ incubator/derby/code/trunk/java/testing/org/apache/derbyTesting/functionTests/harness/RunList.java
Mon Jan 24 11:33:53 2005
@@ -268,8 +268,6 @@
                     	pwOut.println("Cannot run the suite, requires jdk12 or higher, have
jdk" + javaVersion);
 					else if(needJdk14)
                     	pwOut.println("Cannot run the suite, requires jdk14 or higher, have
jdk" + javaVersion);
-					else if(needJdk14)
-                    	pwOut.println("Cannot run the suite, requires jdk14 or higher, have
jdk" + javaVersion);
 					else if(excludedFromJCC)
                     	pwOut.println("Cannot run the suite on JCC version " + excludeJCC +
" or lower.");                                     
                                         else if((needIBMjvm == null || needIBMjvm.booleanValue()
== false))
@@ -921,6 +919,7 @@
 	boolean isIBridge = false;
 	boolean isJdk12 = false; // really now 'isJdk12orHigher'
 	boolean isJdk14 = false;
+	boolean isJdk15 = false;
 	boolean isJdk118 = false;
 	boolean isJdk117 = false;
 	boolean isEncryption = false;
@@ -947,6 +946,7 @@
 	if ( System.getProperty("java.version").startsWith("1.1.8") ) isJdk118 = true;
         if ( System.getProperty("java.version").startsWith("1.1.7") ) isJdk117 = true;
         if ( System.getProperty("java.version").startsWith("1.4.") ) isJdk14 = true;
+        if ( System.getProperty("java.version").startsWith("1.5.") ) isJdk15 = true;
 
         if ( (framework != null) && (framework.length()>0) )
 	{
@@ -1002,7 +1002,7 @@
  	}		
 
         // Skip any suite if jvm is not jdk14 or higher for jdk14test
-        if (!isJdk14 &&  isJdk14Test)
+        if ((!isJdk14 && !isJdk15) &&  isJdk14Test)
 	{
 		needJdk14 = true;
   		return true;

Mime
View raw message