db-ddlutils-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sashik <sashikanth.madd...@gmail.com>
Subject org.apache.ddlutils.io.DataSinkException
Date Wed, 20 Jan 2010 23:29:10 GMT

Hi 

I'm using Ddlutils-1.0.jar, which was jar'ed after checking out trunk from
SVN. For some reason when I'm loading data from my XML file in to MS SQL
Server, I'm getting below exception

 org.apache.ddlutils.io.DataSinkException: There are 8 rows still not
written because of missing referenced rows

I'm not sure why Ddlutils unable to insert records. The DDL Util is supposed
to hold back the insertion of certain referencing rows until the referenced
rows have been posted to the database.The work around is remove foreign key
constraints from schema, insert all data and then add them back again. I
tried to solve this by checking out latest code from SVN trunk, jar'ed using
ANT jar (target). But my problem is not solved. It still says above
exception. 

Can anyone help me in digesting this problem?

1. I tried to jar trunk version and could not able to solve the problem
2. Tried checking out RC2 version and same problem

Someone help me urgently by letting me know how to checkout 1.3 version of
code in my local form Ddlutils source code?

Thanks
Sashi
-- 
View this message in context: http://old.nabble.com/org.apache.ddlutils.io.DataSinkException-tp27250457p27250457.html
Sent from the Apache DdlUtils - User mailing list archive at Nabble.com.


Mime
View raw message