db-ddlutils-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sashik <sashikanth.madd...@gmail.com>
Subject Re: Using DDLUtils 1.3 version
Date Wed, 20 Jan 2010 22:50:11 GMT

Hi there

How can I get Ddltutils version 1.3? When I checkout the trunk and jar it,
I'm getting Ddlutils-1.0.jar still. I need 1.3 version to check one of the
exceptions that I'm getting using 1.0 version. With 1.0 I'm getting 

org.apache.ddlutils.io.DataSinkException: There are 8 rows still not written
because of missing referenced rows

exception. I wanted 1.3 version to see if that still exists. Can I check out
that branch  in order to make 1.3 version jar?

Thanks
Sashi


Thomas Dudziak wrote:
> 
> On Mon, Jan 26, 2009 at 12:11 AM, pmendelson2 <mendelson.paul@gmail.com>
> wrote:
> 
>> I would like to use ddlutils to seed and capture data from an h2
>> database.  I
>> see that support for H2 is slotted for release 1.3.  I also see that
>> there
>> is a major 1.1 release that simplifies the dbms plugin mechanism.
>>
>> If I need to use DDLUtils with h2 today which branch should I download
>> and
>> try to hack into?
> 
> You should checkout trunk, and start with copying the hsqldb platform
> classes which should be relatively similar. The steps then would be
> 
> * get the unit tests running against an H2 database
> * fix the broken unit tests one by one
> 
> For the purpose of the above, it is easier to work with an external H2
> database server instead of using it embedded.
> 
> hope that helps,
> Tom
> 
> 

-- 
View this message in context: http://old.nabble.com/Using-DDLUtils-with-h2database-tp21658131p27250001.html
Sent from the Apache DdlUtils - User mailing list archive at Nabble.com.


Mime
View raw message