db-ddlutils-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Langdon Stevenson <lang...@lindenrow.com.au>
Subject Re: Exception while reading the row from the resultset
Date Sat, 09 Dec 2006 02:13:53 GMT
Some more info on this issue.

I have updated some of the commons jars that I was using to the versions 
supplied with DdlUtils and the data from the DB is now being written to 
the data.xml file.

I am still getting the same error as below.

When I looked at the data I found that it simply stopped part way 
through writing a record.  It was busy writing out line 16,871 in the 
file, so I wondered if there might have been a character or record limit 
that I was running up against.

I inserted another row in a table that is dumped earlier in the process 
and ran the dump again.  As suspected the line count was similar, but I 
had lost a three rows that previously had been in the data file!  It now 
cut off three records earlier in a different place in the line.

This suggests that the quantity of data is larger than ddlutils can handle.

So, does DdlUtils have a known limit to the number of database rows that 
it can export?

Regards,
Langdon



Langdon Stevenson wrote:
> I now have DdlUtils successfully dumping thee database schema, but still 
> have an issue with dumping data.  When I run my build in Ant I get the 
> following error:
> 
> org.apache.ddlutils.DatabaseOperationException: Exception while reading 
> the row from the resultset
> 
> 
> I am stumped as to how to find out the cause of this error.
> 
> Any suggestions appreciated.
> 
> Regards,
> Langdon

Mime
View raw message