db-ddlutils-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Dudziak <tom...@gmail.com>
Subject Re: DatabaseIO does not read
Date Wed, 15 Feb 2006 09:41:58 GMT
On 2/15/06, Christian.Eugster@kost.admin.ch
<Christian.Eugster@kost.admin.ch> wrote:

> by now it seems that DatabaseIO passes in the method getReader() an invalid
> parameter to the method registerMultiMapping():
>
>         reader.registerMultiMapping(new
> InputSource(getClass().getResourceAsStream("/mapping.xml")));
>
> I tried several different paths for "/mapping.xml" (for example put the file
> mapping.xml to c: (as c:\\mapping.xml)) but nothing worked as by now. I am
> trying...

This line means that DdlUtils reads the mapping.xml file from the
classpath, i.e. from within the DdlUtils jar (which contains this file
if built properly). Please check that your ddlutils.jar contains this
file (root level), and if not, rebuild it via Ant.

Tom

Mime
View raw message