db-ddlutils-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Stern <j...@phadd.net>
Subject Bug reports
Date Tue, 14 Apr 2015 11:52:47 GMT
Hi all,

Not sure if this is the best address for bug reports...please let me 
know if some other is preferred.

Issue #1: JdbcModelReader chokes on existing tables that use an 
underscore '_' character in their names.  This is apparently due to a 
misuses of escaping the name via calls such as

"metaData.escapeForSearch(tableName)" which would be appropriate if the 
underscore was some kind of a wildcard search character rather than an 
actual part of the literal table name.   My issues were resolved by 
removing the function call and simply passing the table name.

Issue #2:  In my working installation - messed about with by Eclipse's 
m2e maven plugin - the PrettyPrintingXMLWriter doesn't seem to produce 
simple end tags in the case of XML elements that have no sub-elements:   
e.g.  <tag attr="text" /> vs.  <tag attr="text"></tag>.   The apparent 
absence of this behavior (changed vs. the custom printer in DdlUtils 
1.0) is more verbose, but also causes a large number of regression tests 
to fail where the former behavior is literally expected.   Not sure if 
this was a library configuration issue local to me or a general issue 
with the code update and the tests not being in sync.

It's relatively easy to hand modify a few tests, but the number of tests 
with this issue is large.

-= Josh


Mime
View raw message