db-ddlutils-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Scott Carr (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DDLUTILS-265) Oracle tablename with a '_' doesn't work correctly
Date Tue, 26 Apr 2011 18:47:03 GMT

    [ https://issues.apache.org/jira/browse/DDLUTILS-265?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13025372#comment-13025372
] 

Kevin Scott Carr commented on DDLUTILS-265:
-------------------------------------------

I am seeing this in MySql as well.  I went into DatabaseMetaDataWrapper and removed _ from
the searchStringPattern.  It worked for my MySQL db, but I am sure it will fail for the SQL
Server DB.  Is there a way to set searchStringPattern on a db by db basis?

> Oracle tablename with a '_' doesn't work correctly
> --------------------------------------------------
>
>                 Key: DDLUTILS-265
>                 URL: https://issues.apache.org/jira/browse/DDLUTILS-265
>             Project: DdlUtils
>          Issue Type: Bug
>          Components: Core - Oracle
>            Reporter: Henk Laracker
>            Assignee: Thomas Dudziak
>
> I tested it on the head.
> I have a excisting database with tablenames like "pln_test" or "pln_helloworld"
> If i try to read this database to a model, the fields are not resolved for tables without
a "_" it works
> In the class JdbcModelreader i changed the following
>             //columnData = metaData.getColumns(metaData.escapeForSearch(tableName), getDefaultColumnPattern());
>             columnData = metaData.getColumns(tableName, getDefaultColumnPattern());
> Because the data is retrieved by the jdbc metadata escaping is not needed
> And now it works.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message