db-ddlutils-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jason Kaufmann (JIRA)" <j...@apache.org>
Subject [jira] Commented: (DDLUTILS-265) Oracle tablename with a '_' doesn't work correctly
Date Sat, 19 Feb 2011 11:55:39 GMT

    [ https://issues.apache.org/jira/browse/DDLUTILS-265?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12996763#comment-12996763
] 

Jason Kaufmann commented on DDLUTILS-265:
-----------------------------------------

This fix broke me - using SQL Server 2000 on WinXP.  Tables I have named with an underscore
in them are no longer found.

> Oracle tablename with a '_' doesn't work correctly
> --------------------------------------------------
>
>                 Key: DDLUTILS-265
>                 URL: https://issues.apache.org/jira/browse/DDLUTILS-265
>             Project: DdlUtils
>          Issue Type: Bug
>          Components: Core - Oracle
>            Reporter: Henk Laracker
>            Assignee: Thomas Dudziak
>
> I tested it on the head.
> I have a excisting database with tablenames like "pln_test" or "pln_helloworld"
> If i try to read this database to a model, the fields are not resolved for tables without
a "_" it works
> In the class JdbcModelreader i changed the following
>             //columnData = metaData.getColumns(metaData.escapeForSearch(tableName), getDefaultColumnPattern());
>             columnData = metaData.getColumns(tableName, getDefaultColumnPattern());
> Because the data is retrieved by the jdbc metadata escaping is not needed
> And now it works.

-- 
This message is automatically generated by JIRA.
-
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message