db-ddlutils-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tony Rippy <tonyri...@gmail.com>
Subject Java 1.4 and JAXP
Date Mon, 04 Oct 2010 00:18:33 GMT
Hi Folks,

I just switched my Eclipse project settings to Java 1.4.2, and noticed
some compiler errors in org.apache.ddlutils.io.ModelValidator. It
seems the javax.xml.validation package wasn't added until Java 1.5.0.
Easy to fix, we just need to add a Maven dependency on Apache Xerces2,
which AFAIK is used by the Sun JRE under the hood.

I would have submitted a patch, but I wasn't sure what version of
Xerces we should be using. Any preferences?

- Tony

Mime
View raw message