db-ddlutils-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Markus Böing (JIRA) <j...@apache.org>
Subject [jira] Commented: (DDLUTILS-238) java.sql.SQLException: ORA-01424 missing or illegal character following the escape character
Date Mon, 09 Feb 2009 11:58:59 GMT

    [ https://issues.apache.org/jira/browse/DDLUTILS-238?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12671819#action_12671819
] 

Markus Böing commented on DDLUTILS-238:
---------------------------------------

I took your advice and replaced the ojdbc14.jar by the ojdbc6.jar driver but that didn't change
anything. Same error :-( 

I'm pretty sure that there are no non-ascii characters in table- and columnnames.

To make sure that the error is not caused by any kind of unknown violation (characterset,
locales, timeformats) I created a very simple test schema. 
This is the output of writeSchemaToFile:

<?xml version="1.0"?>
<!DOCTYPE database SYSTEM "http://db.apache.org/torque/dtd/database">
  <database name="unnamed">
    <table name="BOOK">
      <column name="ID" primaryKey="true" required="true" type="INTEGER" size="22" autoIncrement="false"/>
      <column name="TITLE" primaryKey="false" required="false" type="VARCHAR" size="200"
autoIncrement="false"/>
      <column name="PUBID" primaryKey="false" required="false" type="INTEGER" size="22"
autoIncrement="false"/>
      <foreign-key foreignTable="PUBLISHER" name="FK_PUBID">
        <reference local="PUBID" foreign="ID"/>
      </foreign-key>
    </table>
    <table name="PUBLISHER">
      <column name="ID" primaryKey="true" required="true" type="INTEGER" size="22" autoIncrement="false"/>
      <column name="NAME" primaryKey="false" required="false" type="VARCHAR" size="500"
autoIncrement="false"/>
      <column name="CITY" primaryKey="false" required="false" type="VARCHAR" size="100"
autoIncrement="false"/>
    </table>
  </database>

but the writeDataToFile failed again with the same error.

Each of the above tables has one single record:

BOOK.ID=1
BOOK.TITLE='Book1'
BOOK.PUBID=1

PUBLISHER.ID=1
PUBLISHER.NAME='Publisher1'
PUBLISHER.CITY='City1'


I don't know but it looks like as if I have reached the point where any further investigation
exceeds a reasonable relation of effort and result.

Thanks for helping me.
Kind regards
Markus



 

> java.sql.SQLException: ORA-01424 missing or illegal character following the escape character
> --------------------------------------------------------------------------------------------
>
>                 Key: DDLUTILS-238
>                 URL: https://issues.apache.org/jira/browse/DDLUTILS-238
>             Project: DdlUtils
>          Issue Type: Bug
>          Components: Core - Oracle
>    Affects Versions: 1.0
>         Environment: Client: win xp, Apache-ant-1.7.1, jdk 1.6.0, DdlUtils-1.0, ojdbc14.jar
for oracle 10.2.0.4 | Server: Sun 15k, Solaris, Oracle 10.2.0.4
>            Reporter: Markus Böing
>            Assignee: Thomas Dudziak
>         Attachments: log.txt
>
>
> The schema.xml was written completely and correctly but when it comes to extracting the
data, this error occures:
> java.sql.SQLException: ORA-01424 missing or illegal character following the escape character
> If you have a where clause with the like operator and use the ESCAPE expression for example
like
> >where owner LIKE 'SOME-OWNER-SUBSTRING' ESCAPE '/'<
> the character after the escape character in SOME-OWNER-SUBSTRING  _MUST_ be one of  %
or _ to evaluate % or _ literally.
> I've tried different task-parameters like with/without modelname, usedelimitedsqlidentifiers
true or without,only certain tabletypes but all with the same result.
> This is my ant file:
> <project name="MyProject" default="database-dump" basedir=".">
>     <description>
>         Oracle to DDL
>     </description>
>   <property name="database-dump"  location="database-dump"/>
> <path id="runtime-classpath">
>   <fileset dir="lib">
>     <include name="**/*.jar"/>
>     <include name="**/*.zip"/>
>   </fileset>
> </path>
> <target name="database-dump" description="Oracle10-SCHEMA-Dump">
>   <taskdef name="databaseToDdl"
>            classname="org.apache.ddlutils.task.DatabaseToDdlTask">
>     <classpath refid="runtime-classpath"/>
>   </taskdef>
>   <databaseToDdl modelname="SCHEMA" schemapattern="SCHEMA" databasetype="oracle10"
verbosity="DEBUG">
>     <database url="jdbc:oracle:thin:@HOSTIP:1521:SID"
>               driverClassName="oracle.jdbc.driver.OracleDriver"
>               username="SCHEMA"
>               password="PASS"/>
>     <writeSchemaToFile outputFile="schema.xml"/>
>     <writeDataToFile outputFile="data.xml"/>
>   </databaseToDdl>
> </target>
> </project>
> Thanks in advance
> Markus

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message