datafu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eyal Allweil (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DATAFU-80) Enahnce InUDF to support tuple collection from String and Add Java Compatibility for DataFu-Pig
Date Wed, 15 Aug 2018 08:51:00 GMT

    [ https://issues.apache.org/jira/browse/DATAFU-80?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16580850#comment-16580850
] 

Eyal Allweil commented on DATAFU-80:
------------------------------------

Hi [~yiqun],

Any chance you want to return to this issue? If not, I will post it on [Help Wanted|http://helpwanted.apache.org/].

> Enahnce InUDF to support tuple collection from String and Add Java Compatibility for
DataFu-Pig
> -----------------------------------------------------------------------------------------------
>
>                 Key: DATAFU-80
>                 URL: https://issues.apache.org/jira/browse/DATAFU-80
>             Project: DataFu
>          Issue Type: Improvement
>    Affects Versions: 1.3.0
>         Environment: Mac OS X Yosemite
>            Reporter: Yiqun Hu
>            Priority: Minor
>              Labels: features
>         Attachments: DATAFU-80.patch
>
>   Original Estimate: 24h
>  Remaining Estimate: 24h
>
> * Enahnce InUDF to support tuple collection from String
> In many of our application, we need the IN operator for FILTER to operation on a string
representing multiple values e.g. 'AU,SG,HK' for a country list. So we need IN operation to
support something like 
> FILTER users BY IN(country, STRSPLIT('$country_list',',')) 
> where the value of $country_list is 'AU,SG,HK' passed as input parameter.
> I found this one is generally useful for many application. so send the minor enhancement
about it.
> * JAVA Compatibility for DataFu-Pig
> Different JVM version can be used to build DataFu, but the generated jar without java
compatibility support cannot run on the platform using different version of JVM. So add java
compatibility suport in build.gradle.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message