datafu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthew Hayes (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (DATAFU-125) Upgrade Gradle to v4 or later
Date Tue, 28 Nov 2017 00:49:00 GMT

    [ https://issues.apache.org/jira/browse/DATAFU-125?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16267883#comment-16267883
] 

Matthew Hayes commented on DATAFU-125:
--------------------------------------

When I tried applying this change it wasn't running Gradle 3.5.1 as intended when I tested
with {{./gradlew --version}}.  It was still running 2.4 for me.  I think the issue is that
we should be {{gradle.properties}} instead.  Also we should delete these files:

{noformat}
gradle/wrapper/gradle-wrapper.jar
gradle/wrapper/gradle-wrapper.properties
gradlew
{noformat}

These files can all be generated by running {{gradle -b bootstrap.gradle}}.  Whenever you
change the gradle version in {{gradle.properties}} you can rerun this bootstrap command to
update the gradle version.  It was probably a mistake to have these three files checked in.

> Upgrade Gradle to v4 or later
> -----------------------------
>
>                 Key: DATAFU-125
>                 URL: https://issues.apache.org/jira/browse/DATAFU-125
>             Project: DataFu
>          Issue Type: Task
>            Reporter: Matthew Hayes
>            Assignee: Eyal Allweil
>         Attachments: DATAFU-125.patch
>
>
> We should update to the most recent version of Gradle.  We're currently using 2.4.



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message