datafu-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jakob Homan (JIRA)" <j...@apache.org>
Subject [jira] [Created] (DATAFU-95) Improve wrong JDK error message
Date Fri, 05 Jun 2015 22:21:01 GMT
Jakob Homan created DATAFU-95:
---------------------------------

             Summary: Improve wrong JDK error message
                 Key: DATAFU-95
                 URL: https://issues.apache.org/jira/browse/DATAFU-95
             Project: DataFu
          Issue Type: Improvement
            Reporter: Jakob Homan
            Priority: Minor


Right now if one tries to build against JDK1.7, the resulting failure is a bit unclear:
{noformat}Download https://repo1.maven.org/maven2/org/eclipse/equinox/app/1.3.200-v20130910-1609/app-1.3.200-v20130910-1609.jar
/Users/jahoman/repos/datafu/build-plugin/src/main/java/org/adrianwalker/multilinestring/MultilineProcessor.java:18:
error: cannot find symbol
@SupportedSourceVersion(SourceVersion.RELEASE_8)
                                     ^
  symbol:   variable RELEASE_8
  location: class SourceVersion
1 error
:build-plugin:compileJava FAILED

FAILURE: Build failed with an exception.
{noformat}
It may be better to use something like [The Sweeney|https://github.com/boxheed/gradle-sweeney-plugin]
to enforce this and provide a better, faster message on failure.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message