cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kulbhushan Azad <kulbhushan.cu...@gmail.com>
Subject Re: JAXBException with CXF 3.0.11 and Jackson 2.8.6
Date Tue, 18 Apr 2017 15:27:01 GMT
attached the screenshot , see if its okay now

On Tue, Apr 18, 2017 at 11:09 AM, Sergey Beryozkin <sberyozkin@gmail.com>
wrote:

> This image is inlined and is not displayed properly, simply have a look at
> the trace and check which provider is reporting it...
>
> Sergey
> On 18/04/17 15:53, Kulbhushan Azad wrote:
>
>> hi Sergey
>>
>> when i use the provider
>> com.fasterxml.jackson.jaxrs.json.JacksonJaxbJsonProvider i see the error.
>>
>> the earlier version of jackson(1.9.13) provider as
>> org.codehaus.jackson.jaxrs.JacksonJaxbJsonProvider it does not give any
>> error keeping everything else unchanged
>>
>> attaching below the screenshot of the error i see on the console , so
>> not sure whats going on with this and thanks for your help
>>
>> Inline image 1
>>
>> On Tue, Apr 18, 2017 at 9:34 AM, Sergey Beryozkin <sberyozkin@gmail.com
>> <mailto:sberyozkin@gmail.com>> wrote:
>>
>>     Is it reported by JacksonJaxbJsonProvider in response to an
>>     application/json payload ?
>>
>>     Sergey
>>
>>     On 18/04/17 06:33, Kulbhushan Azad wrote:
>>
>>         hi
>>         i am seeing below error while running the rest request from
>> postman
>>
>>         JAXBException occurred : unexpected element (uri:"",
>>         local:"ProjectName").
>>         Expected elements are
>>         <{http:/xxx.xx.com/xxx/xxx/schema/v1}Project
>> <http://xxx.xx.com/xxx/xxx/schema/v1%7DProject>
>>         <http://xxx.xx.com/xxx/xxx/schema/v1%7DProject>>,<{http:/
>>         xxx.xx.com/xxx/xxx/schema/v1}Subproject
>> <http://xxx.xx.com/xxx/xxx/schema/v1%7DSubproject>
>>         <http://xxx.xx.com/xxx/xxx/schema/v1%7DSubproject>>
>>
>>
>>
>>         my corresponding spring configuration:
>>
>>         <bean id="fw.restEndpointParent"
>>         class="org.apache.cxf.jaxrs.JAXRSServerFactoryBean">
>>                 <property name="bus" ref="fw_restServerBus" />
>>                 <property name="extensionMappings">
>>                     <map>
>>                         <entry key="json" value="application/json" />
>>                         <entry key="xml" value="application/xml" />
>>                     </map>
>>                 </property>
>>                 <property name="providers">
>>                     <list>
>>                         <bean
>>         class="com.fasterxml.jackson.jaxrs.json.JacksonJaxbJsonProvider"
>> />
>>                     </list>
>>                 </property>
>>
>>             </bean>
>>
>>          it used to work fine with the CXF 2.7.8 and jackson 1.9.13
>>
>>         Not sure what could be the issue here
>>         would appreciate any help or pointers with respect to this
>>
>>
>>
>>
>>
>>     --
>>     Sergey Beryozkin
>>
>>     Talend Community Coders
>>     http://coders.talend.com/
>>
>>
>>
>>
>> --
>> Thanks
>> Kulbhusan
>>
>
>


-- 
Thanks
Kulbhusan

Mime
  • Unnamed multipart/mixed (inline, None, 0 bytes)
View raw message