cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kai Rommel <krommel2...@googlemail.com>
Subject inconsistency in used spring schemas in 3.1.10-SNAPSHOT
Date Wed, 18 Jan 2017 12:35:17 GMT
Hello,

my build against our company repo fails.

It is complaining about the used namespaces and the referenced spring
schemas.

E.g. checking following beans.xml:
in cxf-rt-rs-extension-providers
file: org/apache/cxf/jaxrs/provider/atom/servers.xml

In 3.1.10-SNAPSHOT the spring version 4.1.9-RELEASE is used. Within the
servers.xml I see following namespace declaration:
...http://www.springframework.org/schema/util" xsi:schemaLocation="
http://www.springframework.org/schema/beans
http://www.springframework.org/schema/beans/spring-beans-4.1.xsd
http://www.springframework.org/schema/util
http://www.springframework.org/schema/util/spring-util-4.3.xsd"

Is spring-util-4.3.xsd used on purpose? Or should it be spring-util-4.1.xsd?
spring-beans-4.1.9.RELEASE.jar does not contain spring-util-4.3.xsd
declaration in /META-INF/spring.schemas file.

In 3.2.0-SNAPSHOT the spring version 4.2.xsd is used:
http://www.springframework.org/schema/beans/spring-beans-4.2.xsd
http://www.springframework.org/schema/util
http://www.springframework.org/schema/util/spring-util-4.2.xsd”


spring-util-4.3.xsd is used in several .xml files in 3.1.10-SNAPSHOT.

Best regards,
Kai

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message