cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Beryozkin <sberyoz...@gmail.com>
Subject Re: Can't Get Jackson jaxrs:providers Working!!!
Date Tue, 18 Aug 2015 21:19:21 GMT

The latest version of CXF ? That would explain it why having Jettison 
was affecting it.
In earlier CXF if the custom provider was matching then the default 
providers were not checked. It proved to be not spec compliant, as the 
spec does require both default and custom providers being considered as 
candidates, even if the matching custom provider is available.
So we have Jettison based provider, typed by Object but is also having 
Consumes/Produces application/json, etc

and Jackson, also typed by Object but using wildcard media types.

therefore Jettison based provider wins using a media type selection criteria

HTH, Sergey


On 18/08/15 22:06, craigrs84 wrote:
> 1. Removing jettison from the classpath fixed the problems!
> 2. I'm running the latest version of CXF
> 3. Sorry, I'm not sure how to migrate this into the Users list other than
> re-creating a new thread, is that what you mean?
>
> It seems that the jettison provider was overriding the jackson provider I
> had configured in my spring xml file.  Is that normal or a bug?  It feels
> like my jackson provider should have overridden the jettison provider based
> on the spring config.
>
>
>
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/Can-t-Get-Jackson-jaxrs-providers-Working-tp5760269p5760277.html
> Sent from the cxf-dev mailing list archive at Nabble.com.
>


-- 
Sergey Beryozkin

Talend Community Coders
http://coders.talend.com/

Mime
View raw message