cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Freddy Exposito <expos...@gmail.com>
Subject WS-SecureConversation not working with .NET client
Date Mon, 11 Aug 2014 20:51:13 GMT
Hi,

I have a .NET client trying to do WS-SecureConversation against a CXF
Service and it is not working. It was working fine until  this commit 
8c40b37ab7fd41482ea4f1e42b4993703ee6be29
<https://git-wip-us.apache.org/repos/asf?p=cxf.git;a=commit;h=8c40b37ab7fd41482ea4f1e42b4993703ee6be29>
 
where the SecureConversationInInterceptor was moved from PRE_PROTOCOL to
PRE_STREAM phase.

What is failing for me now is that the SecureConversationInInterceptor is
not able to get the addressing properties
JAXWSAConstants.SERVER_ADDRESSING_PROPERTIES_INBOUND required to 'get' the
SoapAction when dealing with "//MS/WCF".

What I believe is happening is that this properties is set in the
ContextUtils.storeMaps() ( exec ContextUtils.getMAPProperty() ) method
invoked from the MAPCodec interceptor but this interceptor is still in
PRE_PROTOCOL phase, so now it is not being triggered before the
SecureConversationInInterceptor which is now in PRE_STREAM.

Is it something wrong with .NET integration in CXF or I am missing something
in the configuration?

Thanks,
Freddy









--
View this message in context: http://cxf.547215.n5.nabble.com/WS-SecureConversation-not-working-with-NET-client-tp5747626.html
Sent from the cxf-user mailing list archive at Nabble.com.

Mime
View raw message