cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aaron Titus <ati...@fwdco.com>
Subject [SOLVED] cxf logging and log4j
Date Wed, 18 Jun 2014 14:34:54 GMT
I solved my own problem, but maybe the solution would be helpful to others:
 the issue was the file naming of the configuration file within META-INF in
the classpath.  I had it spelled as 'logger' but it was expecting 'Logger'.
 As usual, capitalization is key!




On Tue, Jun 17, 2014 at 6:16 PM, Aaron Titus <atitus@fwdco.com> wrote:

> I've read the documentation on the CXF web site, and I've also done some
> searches and read a bunch of posts and I still cannot get this working or
> figure out what I am doing wrong. I have :
>
> 1. created the file WEB-INF/classes/META-INF/cxf/org.apache.cxf.logger and
> inside of it placed the content:  org.apache.cxf.common.logging.Log4jLogger
>
> 2. I configured log4j to write the data to a file appender for all
> services using this logger definition:
>  log4j.logger.org.apache.cxf.services=INFO, file1
>
> where file1 is a file appender.
>
> For whatever reason, it seems to refuse to use log4j.  It DOES produce
> logging however it goes into the main catalina.out  log of tomcat and the
> file is empty.  It appears that its still using standard java logging
> still.
>
> Any suggestions as to how I can can track down what is happening? For
> reference this is Apache Tomcat 7.0.42 and CXF 2.7.6, using a java 7 jdk.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message