cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alessio Soldano <asold...@redhat.com>
Subject Re: CXF 2.6.8 issue with JBoss 6.0.1 EAP
Date Thu, 19 Dec 2013 15:30:50 GMT
Hi,
sorry, I'm a bit in hurry and I'd need to check EAP 6.0.1 distribution 
(which I don't have here atm) for a proper reply. I could possibly get 
back on this tomorrow.
Regarding excluding the webservices susbsytem, I think I understand why 
that's not playing a relevant role in your case, sorry.
Regarding the usage of CXF libraries from the container, I'd say please 
double check the jars you need are actually there in the module that 
you're setting a dependency to. As I said previously, the cxf jaxrs libs 
are not shipped. Spring is not shipped (you might need to install it 
into org.springframework.spring module). Moreover, I can't remember if 
that version of EAP had the 'org.apache.cxf.impl' module or not, check 
that too.
Feel free to move this discussion to the jboss user forum if you want 
(perhaps add a link here), there's no CXF issue afaiu, this is more a 
matter of configuring the JBoss container for your app requirements...

Cheers
Alessio

On 19/12/13 15:18, mayankeagle wrote:
> Alessio - I tried excluding the webservices sub-system. I am not including
> the CXF impl JARs in my WEB-INF/lib though. Would it not pick up if I am
> still referring to the CXF and CXF impl modules in the
> jboss-deployment-structure.xml? I understand that 6.0.1 EAP (AS 7.1.2) has
> bug-fixes, etc so I'd assumed existing functionality from 7.1.1 wouldn't get
> broken and I wouldn't have to do anything additional to make CXF
> web-services (note that in 7.1.1, I didn't disable webservices sub-system to
> make JAX-RS work with the CXF modules).
>
> I still get the same error after removing the webservices sub-system. I am
> currently trying with this kind of configuration for the modules CXF, CXF
> impl and Spring:
>
>              <module name="org.apache.cxf" services="import" export = "true">
> 				<imports>
>                  	<include path="META-INF"/>
>                  	<include path="META-INF/cxf"/>
> 				</imports>
> 				<exports>
>                		<include path="META-INF"/>
>                		<include path="META-INF/cxf"/>
> 				</exports>			
> 			</module>
>
> I found this from one of your posts on another site. Should I revert it to
> the earlier:
>
>              <module name="org.apache.cxf" services="import">
>                  <imports>
>                      <include path="META-INF**" />
>                      <include path="org**" />
>                      <include path="schemas**" />
>                  </imports>
> 			</module>
>
>
>
>
>
> --
> View this message in context: http://cxf.547215.n5.nabble.com/CXF-2-6-8-issue-with-JBoss-6-0-1-EAP-tp5737992p5738007.html
> Sent from the cxf-user mailing list archive at Nabble.com.


-- 
Alessio Soldano
Web Service Lead, JBoss


Mime
View raw message