cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Sosnoski <...@sosnoski.com>
Subject Re: RM issue - CreateSequence was not recognized
Date Tue, 24 Sep 2013 07:25:17 GMT
Hi Oleg,

I haven't worked with the JaxWsProxyFactoryBean approach, but isn't this 
Fault coming from the server? You can enable logging to see what is 
actually being sent and confirm where the problem is occurring: 
http://cxf.apache.org/docs/debugging-and-logging.html

   - Dennis

Dennis M. Sosnoski
Java SOA and Web Services Consulting <http://www.sosnoski.com/consult.html>
CXF and Web Services Security Training 
<http://www.sosnoski.com/training.html>
Web Services Jump-Start <http://www.sosnoski.com/jumpstart.html>

On 09/24/2013 06:39 PM, Oleg Tikhonov wrote:
> Hello,
>
> I got
>
> "org.apache.cxf.binding.soap.SoapFault: Message part {
> http://schemas.xmlsoap.org/ws/2005/02/rm}CreateSequence was not recognized."
>
> Here is a code how I create a jaxws client:
>
> [code]
>     public static <T> T getProxyWSHandleReliable(Class<T> clazz, String url)
> {
>          JaxWsProxyFactoryBean factory = new JaxWsProxyFactoryBean();
>          factory.setServiceClass(clazz);
>          factory.setAddress(url);
>          factory.setBindingId(Constants.WSDL_SOAP12);
>          factory.getFeatures().add(new WSAddressingFeature());
>          factory.getFeatures().add(new RMFeature());
>
>          return clazz.cast(factory.create());
>      }
> [/code]
>
> Here is a declaration in the wsdl
> [code]
>      <wsrm:RMAssertion xmlns:wsrm="
> http://schemas.xmlsoap.org/ws/2005/02/rm/policy">
>           <wsrm:InactivityTimeout Milliseconds="600000"/>
>           <wsrm:AcknowledgementInterval Milliseconds="200"/>
>      </wsrm:RMAssertion>
> [/code]
>
>
> How to nail this problem?
>
> Thanks in advance,
>
> Oleg
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message