cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mlobo <ml...@cecropiasolutions.com>
Subject Re: java.lang.NoSuchMethodError after the upgrade of CXF version to 2.4.9 from 2.1.6
Date Tue, 02 Jul 2013 14:32:27 GMT
Daniel Kulp <dkulp@...> writes:

> 
> 
> On Feb 15, 2013, at 2:25 AM, Arjun Bharadwaj H S
> <bharadwaj.arjuna@...> wrote:
> 
> > Hi,
> > 
> > We upgraded the CXF version from 2.1.6 to 2.4.9 and build the ear.
> > When we tried to start the EAR, we are getting the following error:
> > 
> > Invocation of init method failed; nested exception is
> > java.lang.NoSuchMethodError:
> > 
org/apache/ws/commons/schema/XmlSchemaCollection.read(Lorg/w3c/dom/Document;
Ljava/lang/String;)Lorg/apache/ws/commons/schema/XmlSchema;
> > at
> > 
org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory
.initializeBean(AbstractAutowireCapableBeanFactory.java:1338)
> > 
> > What needs to be done to resolve this?
> 
> You need to upgrade the XmlSchema jar as well.  It looks like you are 
picking up a 1.4.x version whereas all
> newer versions of CXF need 2.0.x.
> 
> Dan
> 
> > 
> > We tried 2.5.5 and 2.6.2. We are getting the same error.
> > This upgrade is because of the known security vulnerability mentioned 
here:
> > http://cxf.apache.org/cve-2012-3451.html
> > 
> > Please help us to resolve this issue.
> > 
> > Thanks,
> > Arjun
> 


I'm having the same error updating from 2.3.10 to 2.7.5, XmlSchema jar seems 
to be updated too.


Mime
View raw message