cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: Best CXF client approach for remote WSDL using wsp:Policy
Date Tue, 22 Jan 2013 19:04:10 GMT

On Jan 22, 2013, at 1:59 PM, Bob Ross <supaphr33k@yahoo.com> wrote:

> Another question:
> 
> Can I just download an old version of CXF?

Wouldn't help.

> Did version 2.0.6 support WS Security 1.0 by any chance?

The issue is WS-SecurityPolicy which wasn't introduced into CXF until 2.2 and we really just
targeted 1.1 and newer.

You COULD try grabbing the WSDL with the policies and updating the namespace and policy to
be 1.1 instead of 1.0 and use that local WSDL.   You may need to remap some of the elements
that no longer exist or have changed.



-- 
Daniel Kulp
dkulp@apache.org - http://dankulp.com/blog
Talend Community Coder - http://coders.talend.com


Mime
View raw message