cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Wulff <owu...@talend.com>
Subject RE: 408 response?
Date Tue, 18 Dec 2012 15:06:16 GMT
Hi Frank

Tomcat creates an internal session to cache some information. If the response from the IDP
is sent too late by the browser, the session is gone and fediz returns a 408 error.

HTH

Oli
------

Oliver Wulff

Blog: http://owulff.blogspot.com
Solution Architect
http://coders.talend.com

Talend Application Integration Division http://www.talend.com

________________________________________
From: frank [franksked@gmail.com]
Sent: 17 December 2012 16:40
To: users@cxf.apache.org
Subject: 408 response?

Hi,

I do not yet have a stable test situation, but possibly someone else has
encountered this behaviour as well.

When using Internet Explorer I occasionally receive a 408 response from
Fediz when logging in. Why does this occur? The traces I made suggest that
this may have something to do with the (unexplainable) absence of
JSESSIONID, but when I attempt force this situation manually, I don't get
exactly the same results.

My apologies for not being able to provide more details at this point in
time, but hopefully this rings a bell with someone. I.e. under which
conditions will the Fediz plugin create this response in the following
scenario:

1. I try to reach a URL that is protected by Fediz
2. Fediz redirects me to my IDP
3. I log in and get redirected back to the URL from step 1
4. Fediz comes back with a 408

Any ideas would be helpful.

Cheers,

Frank

Mime
View raw message