cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Pell <ja...@pellcorp.com>
Subject Re: Different WSDL is generated for JDK x64 and x86
Date Wed, 21 Nov 2012 08:27:40 GMT
Actually I noticed in my own environment when I switched from a 32bit
to a 64bit JDK (same patch version), that the output of the WSDL did
change.  It was because I did not specify the propOrder and it
reverted to the reflection default order of properties.

On Tue, Nov 20, 2012 at 8:57 AM, Glen Mazza <gmazza@talend.com> wrote:
> What's the exact error message you're getting--might be helpful to google
> it.
>
> Glen
>
>
> On 11/19/2012 05:43 AM, tomeks wrote:
>>
>> Hi
>> I found strange problem with generated WSDL from CXF 2.7. Content of WSDL
>> differs between x64 and x86 JDK version, what causes Schema Validation to
>> fail. On x86 everything works fine, but on x64 Schema Validation complains
>> about missing element declaration (" Cannot find the declaration of
>> element"
>> ).
>>
>> Its looks like all used jar are the same on both versions (  also Jboss
>> version match ).
>>
>> This isn't probably caused by CXF its self by rather some strange JDK
>> problem, but maybe someone already know the reason for such behaviour.
>>
>> Best regards.
>>
>>
>>
>> --
>> View this message in context:
>> http://cxf.547215.n5.nabble.com/Different-WSDL-is-generated-for-JDK-x64-and-x86-tp5718715.html
>> Sent from the cxf-user mailing list archive at Nabble.com.
>
>
>
> --
> Glen Mazza
> Talend Community Coders - coders.talend.com
> blog: www.jroller.com/gmazza
>

Mime
View raw message