cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Pell <ja...@pellcorp.com>
Subject building cxf 2.6.x-fixes
Date Mon, 01 Oct 2012 02:41:53 GMT
Hi,

I am trying to build cxf 2.6 branch with tests and it fails at
cxf-rt-frontend-jaxrs.

I am building with maven 3 and jdk 1.6.0_32 on linux (Ubuntu 10.10)

I am just doing a mvn clean
then a mv install

The following tests fail:

Failed tests:
testCustomSchemaJaxbContextPrefixes(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testExternalSchemaJaxbContextPrefixes(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testExternalRelativeSchemaJaxbContextPrefixes(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testExternalSchemaCustomPrefix(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testCustomSchemaAndSchemaPrefixes(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testSingleRootResource(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>
  testMultipleRootResources(org.apache.cxf.jaxrs.model.wadl.WadlGeneratorTest):
expected:<1> but was:<0>


I deleted my entire .m2/repository just in case I had some invalid
jars lying around.

The tests are looking for a xsd:long in the generated wadl and I took
a look at it and there are only xsd:int generated.   I suspect this
might be a jaxb version issue?   Should I enable jaxb 2.2 profile to
build this project?

Mime
View raw message