cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rob Sonke <...@tigrou.nl>
Subject Re: Webservice endpoint dissapears after some uptime
Date Thu, 27 Sep 2012 13:47:11 GMT
I solved my own issue (and stupidity). For the record, somewhere else in
our code we had this line to cleanup resources (I thought):
BusFactory.getDefaultBus().shutdown(true);

Everytime that got called, the endpoint was down.

Rob


On Thu, Sep 27, 2012 at 1:24 PM, Rob Sonke <rob@tigrou.nl> wrote:

> Some additional notes for what it's worth. The "services" page isnt
> accessible anymore too. With that I mean the page which lists the soap and
> rest services.
>
> We're running this in combination with spring 3.0.7 on tomcat 7
>
>
> On Thu, Sep 27, 2012 at 12:45 PM, Rob Sonke <rob@tigrou.nl> wrote:
>
>> Hi,
>>
>> Since yesterday we have a nasty issue with our production environment.
>> Yesterday is has been updated to version 2.6.1 and after some hours of
>> uptime, it starts giving these messages:
>>
>> WARNING: Can't find the the request for *url to wsdl file or endpoint*'s
>> Observer
>>
>> From that moment the webservices are down and only a restart seemed to
>> help so far. In the logging I can't find any error (yet), it just starts
>> with this message.
>>
>> Am I doing something wrong? I'll try to upgrade to 2.6.2 asap but none of
>> the fixed issues seem related.
>>
>> Thanks in advance,
>> Rob
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message