cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Glen Mazza <gma...@talend.com>
Subject Re: AW: CXF + Websphere 7 not working
Date Mon, 27 Feb 2012 12:31:52 GMT
There's a *DisableIBMJAXWSEngine* setting I had to use to get Websphere 
to work:
http://www.jroller.com/gmazza/entry/deploying_webservices_on_websphere

HTH,
Glen

On 02/27/2012 06:52 AM, Mark Streit wrote:
> I don't know if this is of any value for the situation you are
> investigating but I posted a reply to another thread relating to "dealing"
> with Websphere 7 (which is never an easy task unless you remain chained to
> its embedded Axis2 stack).  As soon as you attempt to use alternate WS
> stacks like Metro or CXF, trouble starts.
>
> http://cxf.547215.n5.nabble.com/WSDLException-faultCode-CONFIGURATION-ERROR-org-apache-cxf-frontend-WSDLQueryException-td5513793.html#a5514521
>
>
> On Mon, Feb 27, 2012 at 6:20 AM, tapmik<mika.tapanainen@gmail.com>  wrote:
>
>> Hello,
>>
>> I removed the saaj-api-1.3.4.jar from the WEB-INF\lib of the war and still
>> got the exception:
>>
>> Exception created : java.lang.LinkageError: loading constraint violation:
>> loader "com/ibm/ws/classloader/CompoundClassLoader@b100b1" previously
>> initiated loading for a different type with name
>> "org/w3c/dom/DOMConfiguration" defined by loader
>> "com/ibm/oti/vm/BootstrapClassLoader@3b543b54"
>>
>> BR,
>>
>> Mika
>>
>>
>> --
>> View this message in context:
>> http://cxf.547215.n5.nabble.com/CXF-Websphere-7-not-working-tp5518335p5518657.html
>> Sent from the cxf-user mailing list archive at Nabble.com.
>>
>
> *Mark
> *
>


-- 
Glen Mazza
Talend Community Coders - coders.talend.com
blog: www.jroller.com/gmazza


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message