cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From anoordover <anoordo...@live.nl>
Subject SAAJ0511 in axis service
Date Sat, 28 May 2011 13:06:44 GMT
I've got some strange behaviour:
We are in the process of migrating from CXF 2.3.3 to CXF 2.4.0 on a JBoss
AS.
We've got all the cxf jars on the server in the lib directory.
We've got a number of deployed project communicating to a server using AXIS.
These projects work correctly in both 2.3.3 and 2.4.0.
Yesterday I deployed a new project (seperate war) and suddenly the projects
that worked before aren't working anymore and give a SAAJ0511 message about
not being able to create envelope from the source.
When we remove the new project from the server running in 2.4.0 the other
project work correctly.
When we deploy the new project on a server running in 2.3.3 this new project
works correctly.
We haven't tried the functioning of the new project on de 2.4.0 server.

So the strange thing is that deployment of a new war influences the
functioning of another war.
B.t.w. all our project communicate to the same service on the same server
but call different methods.

Does anyone have any idea in what direction we can look for a solution of
this problem.
I didn't expect that deployment of a war could break another war.

So the situation is:
project A
project B

server1 (CXF 2.4.0) with project A is allright.
server2 (CXF 2.3.3) with project B is allright.

server1 (CXF2.4.0) with project A and project B breaks project A.
I haven't tested project B in this setup.


--
View this message in context: http://cxf.547215.n5.nabble.com/SAAJ0511-in-axis-service-tp4434833p4434833.html
Sent from the cxf-user mailing list archive at Nabble.com.

Mime
View raw message