cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ron Grimes <rgri...@sinclairoil.com>
Subject RE: Anyone Successfully Set-up Tomcat 7 with CXF 2.4?
Date Tue, 26 Apr 2011 20:20:27 GMT
Christian,


One more thing, I also changed my web.xml to:

<web-app 
	xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
    xmlns="http://java.sun.com/xml/ns/javaee"
    xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
    				    http://java.sun.com/xml/ns/javaee/web-app_3_0.xsd"
    id="services" version="3.0" metadata-complete="false">


Ron


-----Original Message-----
From: Ron Grimes [mailto:rgrimes@sinclairoil.com] 
Sent: Tuesday, April 26, 2011 2:19 PM
To: users@cxf.apache.org
Subject: RE: Anyone Successfully Set-up Tomcat 7 with CXF 2.4?

Christian,

While I don't have a POM file, I do keep all my project jars in a user library, which is defined
as follows:

    <library name="Endorsed" systemlibrary="false">
        <archive path="C:/UserLibraries/endorsed/aopalliance-1.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/asm-3.3.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-codec-1.5.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-collections-3.2.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-dbcp-1.4.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-fileupload-1.2.2.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-io-2.0.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-lang-2.6.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-logging-1.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-net-2.2.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-pool-1.5.6.jar"/>
        <archive path="C:/UserLibraries/endorsed/commons-vfs-1.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/cxf-2.4.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/dom4j-2.0.0-ALPHA-2.jar"/>
        <archive path="C:/UserLibraries/endorsed/eclipselink.jar"/>
        <archive path="C:/UserLibraries/endorsed/FastInfoset-1.2.9.jar"/>
        <archive path="C:/UserLibraries/endorsed/geoGoogle-1.5.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-activation_1.1_spec-1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-annotation_1.0_spec-1.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-javamail_1.4_spec-1.7.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-jaxws_2.2_spec-1.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-stax-api_1.0_spec-1.0.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/geronimo-ws-metadata_2.0_spec-1.1.3.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpasyncclient-4.0-alpha1.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpclient-4.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpclient-cache-4.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpcore-4.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpcore-nio-4.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/httpmime-4.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/isorelax-20030108.jar"/>
        <archive path="C:/UserLibraries/endorsed/iText-5.0.6.jar" source="C:/UserLibraries/iText-5.0.6/src"/>
        <archive path="C:/UserLibraries/endorsed/jakarta-oro-2.0.8.jar"/>
        <archive path="C:/UserLibraries/endorsed/javaee-api-6.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/javax.persistence_2.0.3.v201010191057.jar"/>
        <archive path="C:/UserLibraries/endorsed/jaxb-api-2.2.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/jaxb-impl-2.2.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/jaxb-xjc-2.2.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/jcifs-1.3.15.jar"/>
        <archive path="C:/UserLibraries/endorsed/jsch-0.1.44.jar"/>
        <archive path="C:/UserLibraries/endorsed/jt400.jar"/>
        <archive path="C:/UserLibraries/endorsed/jt400Native.jar"/>
        <archive path="C:/UserLibraries/endorsed/jt400Proxy.jar"/>
        <archive path="C:/UserLibraries/endorsed/jt400Servlet.jar"/>
        <archive path="C:/UserLibraries/endorsed/mail.jar"/>
        <archive path="C:/UserLibraries/endorsed/msv-core-2010.2.jar"/>
        <archive path="C:/UserLibraries/endorsed/mysql-connector-java-5.0.7-bin.jar"/>
        <archive path="C:/UserLibraries/endorsed/neethi-3.0.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/ojdbc14.jar"/>
        <archive path="C:/UserLibraries/endorsed/poi-3.7-20101029.jar"/>
        <archive path="C:/UserLibraries/endorsed/relaxngDatatype-20020414.jar"/>
        <archive path="C:/UserLibraries/endorsed/saaj-api-1.3.jar"/>
        <archive path="C:/UserLibraries/endorsed/saaj-impl-1.3.2.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-agent-2.5.6.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-aop-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-asm-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-beans-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-context-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-core-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-expression-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-jms-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-ldap-1.3.1.RELEASE-all.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-tx-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/spring-web-3.0.5.RELEASE.jar"/>
        <archive path="C:/UserLibraries/endorsed/stax2-api-3.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/woodstox-core-asl-4.1.1.jar"/>
        <archive path="C:/UserLibraries/endorsed/wsdl4j-1.6.2.jar"/>
        <archive path="C:/UserLibraries/endorsed/xmlbeans-2.4.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/xmlschema-core-2.0.jar"/>
        <archive path="C:/UserLibraries/endorsed/xsdlib-2010.1.jar"/>
    </library>


-----Original Message-----
From: Christian Schneider [mailto:chris@die-schneider.net]
Sent: Tuesday, April 26, 2011 2:04 PM
To: users@cxf.apache.org
Subject: Re: Anyone Successfully Set-up Tomcat 7 with CXF 2.4?

Can you send the pom file, if you use maven?

Christian

Am 26.04.2011 20:26, schrieb Ron Grimes:
> Hi Christian,
>
> I definitely have spring-web-3.0.5.RELEASE in my path.
>
> I'm using the same set of jars for TC7 as I did for my successful implementation of TC6.
The only difference being the javaee.jar that is included. For TC6, I used the javaee version
5, and for TC7 I've tried both the version 5 and 6 jars of javaee.
>
> But, since ContextLoaderListener implements ServletContextListener, this is why I felt
that the reason I can get TC6 working, but not TC7, had to do with the change in the servlet
jar changing from version 2.5 to 3.0. I just don't know exactly what it doesn't like. I've
tried building with both version of javaee within TC7, but to no avail.  All it tells me is
that it can't configure the application listener.
>
> Ron Grimes
>
>
>
> -----Original Message-----
> From: Christian Schneider [mailto:chris@die-schneider.net]
> Sent: Tuesday, April 26, 2011 2:43 AM
> To: users@cxf.apache.org
> Subject: Re: Anyone Successfully Set-up Tomcat 7 with CXF 2.4?
>
> Hi Ron,
>
> from the error message it looks like the spring web jar is not on the classpath.
> Could you send the content of your pom you use to create the war file and of course check
if the above jar is in the lib dir?
>
> Christian
>
>
> Am 26.04.2011 01:16, schrieb Ron Grimes:
>> All,
>>
>> Just a shot in the dark, but has anyone managed to get
>>
>> Tomcat 7
>> CXF 2.4
>> Spring 3.0.5
>>
>> working together?
>>
>> I've been beating my head against a wall with the following error, and am not really
sure what it's complaining about :
>>
>> INFO: Deploying web application archive ssc-maximo.war Apr 25, 2011
>> 4:41:01 PM org.apache.catalina.core.StandardContext listenerStart
>> SEVERE: Error configuring application listener of class 
>> org.springframework.web.context.ContextLoaderListener
>> java.lang.ClassNotFoundException: org.springframework.web.context.ContextLoaderListener
>>         at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1676)
>>         at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1521)
>>         at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:415)
>>         at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:397)
>>         at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:118)
>>         at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4638)
>>         at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5204)
>>         at org.apache.catalina.core.StandardContext$1.call(StandardContext.java:5199)
>>         at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
>>         at java.util.concurrent.FutureTask.run(FutureTask.java:138)
>>         at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
>>         at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
>>         at java.lang.Thread.run(Thread.java:662)
>> Apr 25, 2011 4:41:01 PM org.apache.catalina.core.StandardContext
>> listenerStart
>> SEVERE: Skipped installing application listeners due to previous
>> error(s) Apr 25, 2011 4:41:01 PM
>> org.apache.catalina.core.StandardContext startInternal
>> SEVERE: Error listenerStart
>> Apr 25, 2011 4:41:01 PM org.apache.catalina.core.StandardContext
>> startInternal
>> SEVERE: Context [/ssc-maximo] startup failed due to previous errors
>>
>>
>> I suspected the problem was with the change from servlet-api 2.5 to 3.0. I've tried
configuring it both ways to no avail.
>>
>> I have managed to get Tomcat 6, CXF 2.5, and Spring 3.0.5 working, but, since I'm
finally upgrading from Tomcat 5.5.26, I wanted to push it all the way to TC 7.
>>
>> Any help would be greatly appreciated.
>>
>>
>> Thanks,
>>
>> Ron Grimes
>>
>>
>>
> --
> ----
> http://www.liquid-reality.de
>
>

--
----
http://www.liquid-reality.de


Mime
View raw message