cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nicola zantedeschi <nicolazantedes...@hotmail.it>
Subject RE: Unmarshalling Error: prefix java is not bound
Date Sat, 08 Jan 2011 06:50:35 GMT

Ok, it's correct. But, Why with cxf 2.2.3 the client works without problem?Thanks.

> From: dkulp@apache.org
> To: users@cxf.apache.org
> Subject: Re: Unmarshalling Error: prefix java is not bound
> Date: Fri, 7 Jan 2011 09:22:31 -0500
> CC: nicolazantedeschi@hotmail.it
> 
> On Friday 07 January 2011 8:59:32 am nicola zantedeschi wrote:
> > The response from the server is:
> > 
> > <SOAP-ENV:Envelope
> > xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/">
> > <SOAP-ENV:Header />
> > 
> >     <SOAP-ENV:Body>
> >         <CheckPraticaByGroupResponse
> >             xmlns="http://pdc.gedi.ubiss.it/schema/services">
> >             <objectId>11111</objectId>
> > 
> >             <status xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> >                 xsi:type="java:java.lang.String">COMPLETE</status>
> > 
> >             <placeholders />
> >         </CheckPraticaByGroupResponse>
> >     </SOAP-ENV:Body>
> > </SOAP-ENV:Envelope>
> > 
> > I have a cxf client. The problem should be a problem related to jaxb
> > validation.
> 
> Well, the soap message is definitely NOT valid and the error CXF is producing 
> is correct.  The xsi:type is a qname so the prefix it is trying to find  is 
> "java" which isn't defined anywhere there.   In anycase, the server is 
> generating an invalid SOAP message.   You would need to look there to get it 
> fixed.
> 
> Dan
> 
> 
> 
> > 
> > Thank you.
> > 
> > > Date: Fri, 7 Jan 2011 07:04:17 -0500
> > > Subject: Re: Unmarshalling Error: prefix java is not bound
> > > From: bimargulies@gmail.com
> > > To: users@cxf.apache.org
> > > 
> > > You will have to show us the XML of the message.
> > > 
> > > On Fri, Jan 7, 2011 at 5:01 AM, nicola zantedeschi
> > > 
> > > <nicolazantedeschi@hotmail.it> wrote:
> > > > Hello,
> > > > 
> > > > 
> > > > 
> > > > I have this
> > > > problem with a client created with cxf 2.3.0.
> > > > 
> > > > The
> > > > exception is:
> > > > 
> > > > -----------------------------
> > > > 
> > > > Unmarshalling Error: prefix java is not bound to a
> > > > namespace
> > > > 
> > > > at
> > > > org.apache.cxf.jaxb.JAXBEncoderDecoder.unmarshall(JAXBEncoderDecoder.j
> > > > ava:794)
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.jaxb.JAXBEncoderDecoder.unmarshall(JAXBEncoderDecoder.j
> > > > ava:628)
> > > > 
> > > > 
> > > > at org.apache.cxf.jaxb.io.DataReaderImpl.read(DataReaderImpl.java:154)
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.interceptor.DocLiteralInInterceptor.handleMessage(DocLit
> > > > eralInInterceptor.java:198)
> > > > 
> > > > at
> > > > org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptor
> > > > Chain.java:247)
> > > > 
> > > > at org.apache.cxf.endpoint.ClientImpl.onMessage(ClientImpl.java:733)
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleRes
> > > > ponseInternal(HTTPConduit.java:2201)
> > > > 
> > > > at
> > > > org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.handleRes
> > > > ponse(HTTPConduit.java:2071)
> > > > 
> > > > at
> > > > org.apache.cxf.transport.http.HTTPConduit$WrappedOutputStream.close(HTT
> > > > PConduit.java:1925)
> > > > 
> > > > at
> > > > org.apache.cxf.transport.AbstractConduit.close(AbstractConduit.java:56
> > > > )
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.transport.http.HTTPConduit.close(HTTPConduit.java:662)
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.interceptor.MessageSenderInterceptor$MessageSenderEndin
> > > > gInterceptor.handleMessage(MessageSenderInterceptor.java:62)
> > > > 
> > > > 
> > > > at
> > > > org.apache.cxf.phase.PhaseInterceptorChain.doIntercept(PhaseInterceptor
> > > > Chain.java:247)
> > > > 
> > > > at org.apache.cxf.endpoint.ClientImpl.invoke(ClientImpl.java:516)
> > > > 
> > > > ------------------------------
> > > > 
> > > > The exception is generated when jaxb try to validate
> > > > the response.
> > > > 
> > > > Using cxf 2.2.3 the client work normally, with no
> > > > error.
> > > > 
> > > > 
> > > > 
> > > > Can someone help out with this?
> > > > 
> > > > 
> > > > 
> > > > Thanks!!!
> > > > 
> > > > Nicola.
> 
> -- 
> Daniel Kulp
> dkulp@apache.org
> http://dankulp.com/blog
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message