cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mschipperheyn <m.schipperh...@gmail.com>
Subject Re: CXF Not starting up
Date Thu, 13 Jan 2011 09:39:17 GMT


	<persistence-unit name="ApplicationEntityManager"
		transaction-type="RESOURCE_LOCAL">
		<provider>org.hibernate.ejb.HibernatePersistence</provider>

		<properties>
			<property name="hibernate.hbm2ddl.auto" value="update"/>
			<property name="hibernate.generate_statistics" value="true"/>
			<property name="hibernate.cache.use_second_level_cache" value="true"/>
            <property name="hibernate.cache.use_query_cache" value="true"/>
            <property name="hibernate.cache.region_prefix" value="msa"/>
            <property
name="hibernate.cache.provider_configuration_file_resource_path"
value="/ehcache.xml"/>
			<property name="hibernate.cache.region.factory_class"
value="net.sf.ehcache.hibernate.EhCacheRegionFactory"/>
			<property name="hibernate.search.default.batch.merge_factor" value="1"/>

		</properties>
	</persistence-unit>
</persistence>





<bean id="sessionFactory"
class="org.springframework.orm.hibernate3.annotation.AnnotationSessionFactoryBean">
        <property name="dataSource" ref="dataSource"/>
        <property name="configLocation"
value="classpath:hibernate.cfg.xml"/>
        <property name="hibernateProperties">
            <value>
            	hibernate.bytecode.provider=javaassist
            	hibernate.connection.driver_class=${jdbc.driverClassName}
            	hibernate.connection.is-connection-validation-required=true
                hibernate.dialect=${hibernate.dialect}
                hibernate.use_sql_comments=false
                hibernate.query.substitutions=true
               	hibernate.generate_statistics=true
               
hibernate.search.default.directory_provider=org.hibernate.search.store.FSDirectoryProvider
               
hibernate.search.default.indexBase=${hibsearch.hibernate_index_dir}
                hibernate.search.reader.strategy =
nl.msw.compraventa.dao.hibernate.search.MySharingBufferReaderProvider
                hibernate.search.autoregister_listeners=true
                hibernate.connection.autoReconnect=true
            	hibernate.connection.autoReconnectForPools=true
            	hibernate.show_sql=${hibernate.show_sql}
	    		hibernate.format_sql=${hibernate.format_sql}
	    	
hibernate.cache.region.factory_class=net.sf.ehcache.hibernate.SingletonEhCacheRegionFactory
               
hibernate.cache.provider_configuration_file_resource_path=/ehcache.xml 
				hibernate.cache.use_query_cache=true
                hibernate.cache.use_second_level_cache=true
                hibernate.cache.region_prefix=mercadosa
            </value>
        </property>
		<property name="eventListeners">
			<map>
				<entry key="flush">
					<list>
						<bean class="org.hibernate.event.def.DefaultFlushEventListener" />
					</list>
				</entry>
			</map>
		</property>
		<property name="entityInterceptor">
			<bean class="nl.myproject.dao.hibernate.extension.UseIndexInterceptor"/>
		</property>
    </bean>

-- 
View this message in context: http://cxf.547215.n5.nabble.com/CXF-Not-starting-up-tp3338583p3339480.html
Sent from the cxf-user mailing list archive at Nabble.com.

Mime
View raw message