cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sergey Beryozkin <sberyoz...@gmail.com>
Subject Re: XmlBeans with contentType=text/xml doesn't work
Date Thu, 16 Dec 2010 19:04:24 GMT
Yes, it is just a bug. In addition to updating the Produces/Consumes, you
might also want to
update it to extend
org.apache.cxf.jaxrs.provider.AbstractConfigurableProvider so that users
can just inject required media types

cheers, Sergey

On Thu, Dec 16, 2010 at 6:59 PM, Daniel Kulp <dkulp@apache.org> wrote:

> On Thursday 16 December 2010 1:30:13 pm rahulsom wrote:
> > I'm using CXF with JAXRS and XmlBeans. I had been testing my rest service
> > with contentType=application/xml and it works.
> > Then someone tested it with contentType=text/xml and got a 415 http code.
> >
> > I looked at
> >
> http://svn.apache.org/repos/asf/cxf/trunk/rt/frontend/jaxrs/src/main/java/o
> > rg/apache/cxf/jaxrs/provider/XMLBeansElementProvider.java
> >
> > It looks like the provider only deals with application/xml.
> >
> > I've created a custom implementation the consumes and produces
> > "application/xml", "application/*+xml", "text/xml".
> >
> > Is there a reason that this provider only serves application/xml and I
> > should be using something else? Or is it a bug?
>
> Likely a bug.    Could you file it and attach a patch that adds the extra
> types?
>
> Thanks!
> --
> Daniel Kulp
> dkulp@apache.org
> http://dankulp.com/blog
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message