cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tobias Westerblom <tobias.westerb...@cubeia.com>
Subject Re: NullPointerException in TransportFinder for STSClient - stacktrace
Date Tue, 30 Nov 2010 08:42:02 GMT
Thanks for your answer.

I have tried to configure STS/Trust credentials in various ways according to
the page: http://cxf.apache.org/docs/ws-secureconversation.html.

The NPE-stacktrace indicates that the stsclient fails even before it tries
any call which leads me to think that is not any credentials-related
configuration issue.

None of the interop-fest examples are using the RequireInternalReference in
WS-SecurityPolicy that is causing my warning in the log.

Do I normally have to configure the location of the STS? The ws-security
interop-fest examples doesn't do that.

Shouldn't the STS endpoint be automatically configured by the main wsdl?

Thanks in advance,
Tobias Westerblom


2010/11/29 Daniel Kulp <dkulp@apache.org>

>
> What does your configuration for the client look like?  For the STS/Trust
> stuff, you would have needed to configure in the information about the STS
> to
> contact to get the IssuedToken to use to then get the SecureConversation
> token.
>
> Dan
>
>
>
> On Monday 29 November 2010 7:16:29 am towe wrote:
> > Bump.
> >
> > It there really no one else that have this problem?
> >
> > The key question is: is RequireInternalReference in WS-SecurityPolicy
> > supported?
> >
> > Regards,
> > Tobias Westerblom
>
> --
> Daniel Kulp
> dkulp@apache.org
> http://dankulp.com/blog
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message