cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: cxf 2.3 and Jetty 7
Date Thu, 28 Oct 2010 14:49:06 GMT

Created a JIRA to make sure this is tracked:
https://issues.apache.org/jira/browse/CXF-3099

dan


On Thursday 28 October 2010 9:35:04 am Stephane Nicoll wrote:
>    - groovy_spring_support does not compile because it relies on Jetty 6
>    - rubby_spring_support, ditto
>    - The following have a spring config relying on Jetty 6
>       - js_browser_client_java_first
>       - js_browser_client_simple
> 
> S.
> 
> On Wed, Oct 27, 2010 at 1:41 PM, Benson Margulies 
<bimargulies@gmail.com>wrote:
> > Which samples have org.mortbay.jetty in them?
> > 
> > On Wed, Oct 27, 2010 at 3:23 AM, Stephane Nicoll
> > 
> > <stephane.nicoll@gmail.com> wrote:
> > > Hi there,
> > > 
> > > I started from the base and thought the samples would answer my
> > > original issue. I downloaded the official apache-cxf 2.3.0
> > > distribution from apache.org, had a look and found all kinds of
> > > reference to
> > > "org.mortbay.jetty". If I try to run these samples, I am getting an
> > 
> > obvious
> > 
> > > ClassNotFoundException since Jett7 is used.
> > > 
> > > However, jax_rs\basic_https is working fine and I copy/pasted the
> > > cherryServer.xml in my project but jetty does not seem to start.
> > > 
> > > What am I missing? Especially since the same config works just fine
> > > with 2.2.11 (and Jetty 6)
> > > 
> > > S.
> > > 
> > > On Wed, Oct 20, 2010 at 10:41 AM, Willem Jiang <willem.jiang@gmail.com
> > >
> > >wrote:
> > >> There is no other different configuration on the jetty7 to start the
> > >> embedded server.
> > >> Can you take a look at the CXF 2.3.0 system tests, we didn't face that
> > 
> > kind
> > 
> > >> of issue before?
> > >> 
> > >> BTW, what's address that your service was published?
> > >> 
> > >> On 10/20/10 4:14 PM, Stephane Nicoll wrote:
> > >>> Hi,
> > >>> 
> > >>> We are trying to upgrade our application from 2.2.10 to 2.3.0 and
> > >>> we're facing an issue with embedded Jetty7
> > >>> 
> > >>> We have a set of unit tests starting CXF with an embedded jetty.
> > >>> First
> > 
> > we
> > 
> > >>> had to rename some classes since the move to eclipse but the real
> > >>> issue
> > 
> > is
> > 
> > >>> that while CXF states it has deployed our Web Service, all the unit
> > 
> > tests
> > 
> > >>> are failing with a ConnectionException now.
> > >>> 
> > >>> Do you have a working setup somewhere of embedded jetty with unit
> > >>> tests and
> > >>> cxf 2.3? I had a look to the doc but it does not seem up to date in
> > 
> > that
> > 
> > >>> area.
> > >>> 
> > >>> Thanks,
> > >>> S.
> > >> 
> > >> --
> > >> Willem
> > >> ----------------------------------
> > >> Open Source Integration: http://www.fusesource.com
> > >> Blog:    http://willemjiang.blogspot.com (English)
> > >> 
> > >>         http://jnn.javaeye.com (Chinese)
> > >> 
> > >> Twitter: http://twitter.com/willemjiang

-- 
Daniel Kulp
dkulp@apache.org
http://dankulp.com/blog

Mime
View raw message