cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: What is so different about CXF with WebSphere 6.1 on AIX?
Date Thu, 04 Feb 2010 21:48:34 GMT

We recently added some updated docs about using CXF with 6.1.0.29 that IBM provided:

http://cxf.apache.org/docs/application-server-specific-configuration-guide.html#ApplicationServerSpecificConfigurationGuide-Websphere

Can you double check the instructions that are there?

Dan


On Thu February 4 2010 3:27:13 pm adam galloway wrote:
> I have a CXF 2.2.4 application running fine in WebSphere 6.1.0.29 on
>  Ubuntu. Using the Application Server Specific Configuration Guide in
>  WebSphere on Ubuntu I simply create a shared library with a classpath
>  value pointing to wsdl4j-1.6.2.jar and add that shared library to a new
>  "application first" class loader at the server configuration level.  I
>  restart the server and all runs fine.
> 
> I do the exact same steps with WebSphere 6.1.0.29 on AIX and I get saaj
> exceptions.
> 
> I then tried adding saaj-imp, saaj-api and jaxp-ri to the shared library
>  and it gives me a classnotfound exception for StAXResult.
> 
> I then add jaxp-api to the shared library and it gives me
> 
> java.lang.ClassCastException:
> com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderFactoryImpl
> incompatible with javax.xml.parsers.DocumentBuilderFactory
> 
> This runs great on WebSphere with Ubuntu, I'm struggling to find a
> difference in the two.
> 
> Any help would be appreciated.
> 

-- 
Daniel Kulp
dkulp@apache.org
http://www.dankulp.com/blog

Mime
View raw message