cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Kulp <dk...@apache.org>
Subject Re: .ServiceConstructionException: Could not resolve a binding for null
Date Thu, 03 Dec 2009 20:31:11 GMT


Data is definitely missing from your question....

What version of CXF?

Can you provide the full stack trace?

What annotations are on the Service and Interface?

The applicationContext.xml content wasn't in the message either.

Dan




On Wed November 25 2009 6:30:48 am Ralf Heydenreich wrote:
> Hi all,
> this question occured long time ago, but the submitted solution (adding
>  cxf.xml) didn't work for me. I receive the following exception when I
>  deploy a Webservice client: 
>  Factory method [public ja
> va.lang.Object
>  org.apache.cxf.jaxws.JaxWsProxyFactoryBean.BeanFactory.java:558) at
>  org.springframework.context.support.AbstractApplicationContext.finishBeanF
> actoryInitialization(AbstractApplicationContext.java:852) at
>  org.springframework.context.support.AbstractApplicationContext.refresh(Abs
> tractApplicationContext.java:422) 
> ...and so on.
>  
> The server which provides the webservice is up and running and I can get
>  results from it if I test it via webbrowser or so. My
>  applicationContext.xml has the following entries: 
> 
> 
> 
>  
> 
> 
> 
> 
>  
> 
>  
> Am I missing something?
>  
> TIA,
> Ralf
>  
> 
> --
> 

-- 
Daniel Kulp
dkulp@apache.org
http://www.dankulp.com/blog

Mime
View raw message