cxf-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexandre Jaquet <alexjaq...@gmail.com>
Subject javax.xml.ws.soap.SOAPFaultException: Could not send Message.
Date Mon, 19 Oct 2009 06:14:17 GMT
Hi,

Without using SSL my application is working fine, but now when I'm been
trying to setup SSL with the following configuration nothing work

    <http:conduit name="*Z_WS_ACC_DOCUMENT_POSTPort.http-conduit">
        <http:authorization>

<sec:UserName>${webservice.sap.Z_WS_ACC_DOCUMENT_POST.username}</sec:UserName>

<sec:Password>${webservice.sap.Z_WS_ACC_DOCUMENT_POST.password}</sec:Password>
        </http:authorization>
        <http:tlsClientParameters secureSocketProtocol="SSL">
          <sec:trustManagers>
          <sec:keyStore type="JKS" password="${keystorePassword}"
               file="D:\bea\jrockit-jdk1.5.0_14\jre\lib\security\cacerts"/>
          </sec:trustManagers>
          <sec:keyManagers keyPassword="">
           <sec:keyStore type="JKS" password="${keystorePassword}"
                file="D:\bea\jrockit-jdk1.5.0_14\jre\lib\security\cacerts"/>
          </sec:keyManagers>
        </http:tlsClientParameters>
    </http:conduit>

The only error message I receive is that

2009-10-19 08:05:03 ERROR -
ch.fr.xxx.yyyy.webservices.sap.WebServiceIBANCreate:44 - Exception :
javax.xml.ws.soap.SOAPFaultException: Could not send Message.

Any idea ?

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message